User account lost ability to connect to remote desktop

Brass Contributor

I have a user that has been connecting over our VPN to her desktop for months. Two days ago, it started to fail to connect (basically the generic 'couldn't connect' message in the Windows store RD client). Using my account or any other account we can easily connect to her PC, just not her account. We tried having her connect to several different PC's but all fail, just on her user account, so this is not the PC or it's settings, it's her account. Plus it was working fine for a long time right up until it started failing, no changes at all in her account, groups, etc.


I went into her account just to double check she's part of the remote users group, is allowed on the machine, passwords okay, etc. Everything looks fine, she just can no longer connect. The only thing I can think of is some update either on the server or all the clients have cut her off for some reason? It's definitely tied to her user account as a bunch of other accounts (including mine) work fine. The PC is 1909, the AD server is Windows Server 2019 v.1809, fully patched/up to date. 


Anyone seen this? Is her AD account somehow corrupt or some new security thing come out and bork this connection? Any help greatly appreciated as we just had the preliminary report of another user, but still have to confirm. 


2 Replies

@Curt Kessler More info--we've now had three people (our whole accounting team and primary users of RD) that can't get back into their machines, so it's spreading. Some things we've seen:


I can still get in (but am an administrator) to any PC I connect to (all admin accts seem to be fine)

Remoting in with GoTo Assist still works, the PC's are fine

All three broken users are in remote desktop group

All machines internally are on 1909 Windows

Opening a Windows VM on server and logging in directly under a broken user still works

Local login to the PC still works for users


@Curt Kessler And yet some more information. This appears to be a problem with the Windows store RDP client (both normal and release preview). The old 'classic' ugly application seems to work if we connect to the IP address directly. So it's maybe not the accounts but the client app. 


Oddly, the modern client application works fine for administrator accounts to PC's, VM's and servers. Only standard users fail. Some new 'enhanced security' bumping out users?