Unable to open OWA on chrome , Firefox and also on android My users are unable to open OWA on chrome

%3CLINGO-SUB%20id%3D%22lingo-sub-2296972%22%20slang%3D%22en-US%22%3EUnable%20to%20open%20OWA%20on%20chrome%20%2C%20Firefox%20and%20also%20on%20android%20My%20users%20are%20unable%20to%20open%20OWA%20on%20chrome%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2296972%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20guys%2C%3C%2FP%3E%3CP%3EMy%20users%20are%20unable%20to%20open%20OWA%20on%20chrome%20%2C%20Firefox%20and%20also%20on%20android.%20IE%20works%20fine%20and%20safari%20I'm%20running%20on%20exchange%202013%20cu%2013%2C%20running%20on%20windows%20server%202012.%20Global%20sign%20SSL%20report%20%3A%3CA%20href%3D%22https%3A%2F%2Fglobalsign.ssllabs.com%2Fanalyze.html%3Fd%3Dmail.kura.go.ke%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fglobalsign.ssllabs.com%2Fanalyze.html%3Fd%3Dmail.kura.go.ke%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2296972%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EActive%20Directory%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENetworking%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESecurity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Contributor

Hello guys,

My users are unable to open OWA on chrome , Firefox and also on android. IE works fine and safari I'm running on exchange 2013 cu 13, running on windows server 2012. Global sign SSL report :https://globalsign.ssllabs.com/analyze.html?d=mail.kura.go.ke

0 Replies