Unable to install Windows Server Backup on Windows 2019 Essentials

%3CLINGO-SUB%20id%3D%22lingo-sub-2435232%22%20slang%3D%22en-US%22%3EUnable%20to%20install%20Windows%20Server%20Backup%20on%20Windows%202019%20Essentials%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2435232%22%20slang%3D%22en-US%22%3E%3CP%3ETrying%20to%20install%20Windows%20Server%20Backup%20feature%20on%20a%20newly%20installed%20Windows%202019%20Essentials%20server.%20When%20trying%20to%20install%20it%20comes%20back%20with%20the%20below%20error%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EInstall-WindowsFeature%20%3A%20The%20request%20to%20add%20or%20remove%20features%20on%20the%20specified%20server%20failed.%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3EInstallation%20of%20one%20or%20more%20roles%2C%20role%20services%2C%20or%20features%20failed.%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3EThe%20source%20files%20could%20not%20be%20found.%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3EUse%20the%20%22Source%22%20option%20to%20specify%20the%20location%20of%20the%20files%20that%20are%20required%20to%20restore%20the%20feature.%20For%20more%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3Einformation%20on%20specifying%20a%20source%20location%2C%20see%20%3CA%20href%3D%22http%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3FLinkId%3D243077%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttp%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3FLinkId%3D243077%3C%2FA%3E.%20Error%3A%200x800f081f%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3EAt%20line%3A1%20char%3A1%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3E%2B%20Install-WindowsFeature%20Windows-Server-Backup%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3E%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3E%2B%20CategoryInfo%20%3A%20InvalidOperation%3A%20(%40%7BVhd%3D%3B%20Credent...Name%3Dlocalhost%7D%3APSObject)%20%5BInstall-WindowsFeature%5D%2C%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3EException%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3E%2B%20FullyQualifiedErrorId%20%3A%20DISMAPI_Error__Failed_To_Enable_Updates%2CMicrosoft.Windows.ServerManager.Commands.AddWind%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSTRONG%3EowsFeatureCommand%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CBR%20%2F%3EWhen%20looking%20at%20the%20available%20features%20the%20Backup%20feature%20is%20displaying%20this%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%5B%20%5D%20Windows%20Server%20Backup%20Windows-Server-Backup%20Removed%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHave%20tried%20to%20download%20an%20ISO%20of%20the%20OS%20and%20installing%20using%20DSIM%20with%20the%20source%20switch%2C%20as%20well%20as%20the%20Install-Windowsfeature%20within%20Powershell.%20All%20advising%20that%20the%20source%20files%20cannot%20be%20found.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20everything%20I%20can%20think%20of%20to%20get%20this%20installed.%26nbsp%3B%20Any%20suggestions%20would%20be%20appreciated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESean%20Buckle%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2435232%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2435386%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20install%20Windows%20Server%20Backup%20on%20Windows%202019%20Essentials%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2435386%22%20slang%3D%22en-US%22%3E%3CP%3ESounds%20like%20the%20OS%20may%20be%20broken.%20You%20can%20try%20repairing%20servicing%3C%2FP%3E%0A%3CP%3Esfc%20%2Fscannow%3C%2FP%3E%0A%3CP%3Edism%20%2Fonline%20%2Fcleanup-image%20%2Frestorehealth%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2704492%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20install%20Windows%20Server%20Backup%20on%20Windows%202019%20Essentials%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2704492%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F51719%22%20target%3D%22_blank%22%3E%40Dave%20Patrick%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20same%20problem%20with%20Server%202019%20so%20followed%20your%20below%20instructions%2C%20however%2C%20it%20did%20not%20fix%20the%20situation.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Esfc%20%2Fscannow%3C%2FP%3E%3CP%3Edism%20%2Fonline%20%2Fcleanup-image%20%2Frestorehealth%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20other%20suggestions%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2733525%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20install%20Windows%20Server%20Backup%20on%20Windows%202019%20Essentials%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2733525%22%20slang%3D%22en-US%22%3EDid%20you%20fix%20this%20problem%20as%20I%20am%20having%20same%20problem%3F%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%2C%3C%2FLINGO-BODY%3E
Occasional Contributor

Trying to install Windows Server Backup feature on a newly installed Windows 2019 Essentials server. When trying to install it comes back with the below error:

 

Install-WindowsFeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more
information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. Error: 0x800f081f
At line:1 char:1
+ Install-WindowsFeature Windows-Server-Backup
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],
Exception
+ FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind
owsFeatureCommand

When looking at the available features the Backup feature is displaying this:

 

[ ] Windows Server Backup Windows-Server-Backup Removed

 

Have tried to download an ISO of the OS and installing using DSIM with the source switch, as well as the Install-Windowsfeature within Powershell. All advising that the source files cannot be found.

 

I have tried everything I can think of to get this installed.  Any suggestions would be appreciated.

 

Sean Buckle

5 Replies

Sounds like the OS may be broken. You can try repairing servicing

sfc /scannow

dism /online /cleanup-image /restorehealth

 

 

 

@Dave Patrick 

 

I have same problem with Server 2019 so followed your below instructions, however, it did not fix the situation.

 

sfc /scannow

dism /online /cleanup-image /restorehealth

 

Any other suggestions?

 

Thanks for your help.

Did you fix this problem as I am having same problem?

Thanks,

I am having the same issue on Server 2019 Std. Any one have a fix for this yet?
I have tried the following commands:

dism.exe /online /Cleanup-Image /StartComponentCleanup

dism /online /cleanup-image /restorehealth

sfc /scannow

 

They all succed with 100% and no errors. then once I run the installation, it comes back with no source found.. even if I provide source file from the wim or from another server, same issue.. very frustrating..

 

PS C:\Windows\system32> install-windowsfeature windows-server-backup
install-windowsfeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more
information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. Error: 0x800f081f
At line:1 char:1
+ install-windowsfeature windows-server-backup
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],
Exception
+ FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind
owsFeatureCommand

Success Restart Needed Exit Code Feature Result
------- -------------- --------- --------------
False No Failed {}

@SeanBuckle45 

You can try this fix

 

1) Run PowerShell as an Administrator

2) Put the Original Installation ISO for the OS (Windows Server) and mount it

3) Run this command in PowerShell: Dism /get-wiminfo /wimfile:<drive>:\sources\install.wim
"<drive> -> The Drive letter where this OS ISO was mounted to"

4) Take note of the "Index #" of the OS that was install on the PC (Server)
"For Example: -> Index: 4 , Name: Windows Server 2016 SERVERDATACENTER"

5) Run the next command in PowerShell: Install-WindowsFeature <Name of Feature> -Source wim:<Drive Letter>:\sources\install.wim:<Index #>
"For Example: -> Install-WindowsFeature Windows-Server-Backup -Source wim:G:\sources\install.wim:4"

 

P.S> Do not use the quotation marks "" on PowerShell when running the above commands