Unable to access shared folder

Copper Contributor



I have one shared folder. when i am trying to access it OR trying to change its permission it is not allowing me and says access denied.


I tried it using Domain Administrator. It give below error.


"Failed to enumerate object in container. Access denied."


If i take ownership of folder after that i can access only that particular folder but if i try to access subfolder OR files located in it then it will again says Access denied.


Inheritance is already enabled.

Domain admin has full permission on folder.


Server is located on premise.





Is there any fix for above issue ?

7 Replies
And can you enable inheritance on that subfolder and access it then? Seems like it was all removed?
Whenever I open subfolder property it says you must have read permission to view properties of this object.
If I take ownership of it and enable inheritance then it only applies to particular that folder not on subfolder and files.

It's a lot of work if there are so many folders with inheritance disabled, you can take ownership of a folder and enable inheritance... But that's from above going downwards until you have a folder with inheritance disabled.

I think this is a solution for you, PowerShell :) https://itluke.online/2018/02/02/how-to-reset-file-or-folder-permissions-with-powershell/ Test it on one folder first in which you have that problem, a sub/sub-folder so to say. You have to run "Install-Module -Name NTFSSecurity" first to install the needed module.

Trying to install module on power shell ISE but it says that "The term is not recognised as the name of cmdlet"
Object not found.
Ok..., did an install just now in a PowerShell 7 prompt, and in Windows ISE, Install-Module -Name NTFSSecurity works fine...
It was not working on server where shared folder is located but on my workstation it was working fine.
I ran command from my workstation's powershell and it worked.
I checked many random folders and now I am able to access folder.

Thank you for your help.

Ah, good to hear :) Please mark my answer as solution to mark this topic as solved