Server 2019 Indexing incomplete results

Copper Contributor

Hi. I have a 2019 server. Wich is indexing my network drives. The index always turns up incomplete, meaning it's missing countless files. Some files in a folder is indexed and others are not. So my search results are incomplete.


I've tried rebuilding several times, restarted the server. Rebuild again. The search results are the same every time. Some files are indexed, others are not.


Heres an example on 2 files that are and are not indexed. They are residing in the same folder.


6063 - P295 GH KEDELPLADE 90 - charge AHF724-02-06 plade 623593A - LM 507381.pdf (is indexed every time)

6075 - P295 GH KEDELPLADE 70 - charge AHF732-02-01 plade 624083A - LM 507381.pdf (is never indexed)


Both resides in the same folder. It seems like it stops indexing when it reaches a specific size or similar. The windows.edb file is 10.944.512 KB  But I can't seem to find a setting that should prevent it growing bigger. It's placed on a drive that has 199 Gb and 184 GB free data. Its an NTFS drive.


Tried all possible solutions. Theres no errors in the event log, the indexer runs fine. It states that it has indexed 1.730.583 Items. And that the Indexing is complete.


The fileserver, was replaced recently with a Fresh 2019 install. And since then, the error has persisted. The old server. A 2012R2, never had any issues regarding the search index.


Any good suggestions

3 Replies

I've found the error myself. It seems that SYSTEM should have rights in the folders. Dooh !



Poor you