Remote Desktop Services Deployment fails with exceptions

%3CLINGO-SUB%20id%3D%22lingo-sub-2272987%22%20slang%3D%22en-US%22%3ERemote%20Desktop%20Services%20Deployment%20fails%20with%20exceptions%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2272987%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20trying%20to%20deploy%26nbsp%3BRemote%20Desktop%20Services%26nbsp%3Bon%20a%20single%20server%20on%20%3CSTRONG%3EWindows%20Server%202019%20Standard%3C%2FSTRONG%3E.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20both%20%3CU%3EStandard%20Deployment%3C%2FU%3E%20and%20%3CU%3EQuick%20Start%3C%2FU%3E%20with%20a%20%3CU%3ESession-based%20desktop%20development%3C%2FU%3E%20but%20I'm%20getting%20the%20following%20error%20during%20the%20installation%3A%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-applescript%22%3E%3CCODE%3EUnable%20to%20add%20server%20REMOTEAPP.AD.DOMAIN.COM%20to%20the%20list%20of%20servers%20on%20the%20RD%20Connection%20Broker%20server%20REMOTEAPP.AD.DOMAIN.COM..Exception%20of%20type%20'System.Runtime.InteropServices.COMException'%20was%20thrown.%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22Screenshot%202021-04-14%20at%2016.58.23.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F272884iE59DA641ABC15C74%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Screenshot%202021-04-14%20at%2016.58.23.png%22%20alt%3D%22Screenshot%202021-04-14%20at%2016.58.23.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20searched%20for%20some%20hint%20about%20this%20problem%20but%20I%20had%20not%20find%20anything%20useful.%3C%2FP%3E%3CP%3EI%20cannot%20even%20find%20any%20useful%20log%20into%20the%20events%20log%2C%20and%20I%20tried%20one%20more%20time%20after%20reinstalling%20the%20server%20from%20scratch.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20you%20help%20me%20please%3F%3C%2FP%3E%3CP%3EThank%20you%20very%20much!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2272987%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Erds%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ERemote%20Desktop%20Services%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Eremoteapp%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

I'm trying to deploy Remote Desktop Services on a single server on Windows Server 2019 Standard.

 

I've tried both Standard Deployment and Quick Start with a Session-based desktop development but I'm getting the following error during the installation:

Unable to add server REMOTEAPP.AD.DOMAIN.COM to the list of servers on the RD Connection Broker server REMOTEAPP.AD.DOMAIN.COM..Exception of type 'System.Runtime.InteropServices.COMException' was thrown.

 

Screenshot 2021-04-14 at 16.58.23.png

 

I searched for some hint about this problem but I had not find anything useful.

I cannot even find any useful log into the events log, and I tried one more time after reinstalling the server from scratch.

 

Could you help me please?

Thank you very much!

 

1 Reply
We had the same error that has taken several days to find a fix. Turned out to be some corrupt install files on a Windows Server template. Every VM we spun up from the template experienced the same error. It was resolved by running the DISM command.

For us, we did the following and this resolved RDS installation.
1. remove what RDS installation is currently on the server.
2. make sure windows updates are up to date.
3. open a command prompt in administrative mode/ elevated mode.
4. sfc /scannow
5. dism /online /cleanup-image /restorehealth
6. attempt to install RDS again

Check https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/dism-image-management-command-...