RDS 2019 Remote Apps RDWEB event id 10

Iron Contributor

Hi everyone,

I have a server that I was able to publish remote apps before several new applications installations today. I was also able to use the GPO "Specify the default connection URL

After the installation of the new software, I wanted to publish it. However, it didn't work. I check it using the rdweb URL and found this:


When I went to the server I found event id 10: "RD Web Access was unable to access RDSSerever, which is the server that is specified as running the RemoteApp and Desktop Connection Management service. Ensure that the computer account of the RD Web Access server is a member of the TS Web Access Computers security group on RDSServer."

I tried multiple solutions, but: 1. I don't have a group called TS Web Access Computers Security group 2. Even after changing the authentication  to a domain admin it still doesn't work...


Is my only option to remove and add the RDS again?



1 Reply

@RahamimL hi,


for this issue you need check Computer GPO on User Rigths Assignment, if you have custom configuration try unset all and force GPO update.

This change work for me.