RDP Licensing Server Issue

Contributor

We have a number of terminal servers, all running Server 2019. For most purposes they are standalone (they each handle their own connection broker service), and the only shared resource is the licensing server, which is a dedicated VM  (also Server 2019) which does nothing apart from act as the licensing server. From when set up about a year ago (session hosts and licensing server) all worked fine until a couple of months ago when three (so far) of the terminal server started randomly giving the following error:

RDS Error.JPG

 

If the user logs out and back in it may or may not clear, and if it doesn’t (or if they just ignore it and carry on), it will kick them out after an hour.

 

I have been unable to find any pattern to this – it seems to affect random users at random times, and I have been unable to replicate it in testing. If I run the licensing dignoser (lsdiag.msc) on one of the affected terminal servers when a user informs me of the issue, it comes back with no errors. Connectivity to the licensing server is fine and there are plenty of licenses available.

 

I have tried removing cached user profiles from the affected terminal servers (we use roaming profiles so they re-sync when the user next logs in), which hasn’t helped. Each terminal server is configured to address the licensing server just by its hostname, but on each of those affected I have also added the FQDN and the static IP – which has also had no impact.

 

Can anyone suggest anything else to try?

 

Thanks

2 Replies
Does the eventlog Microsoft-Windows-TerminalServices-Licensing give any more information on the license server
Hi,

No, it doesn't - nothing in there related to the error so far as I can seen.