Hyper-V Nat network

Occasional Contributor

I would like RDP from the Hyper-V host to the virtual machines, RDP is enabled on the VM's, but I still can't.

I also create a NAT rule but it still doesn't work.

4 Replies
Hi @guidovbrakel,

you have to provide a lot of more information (!)

Best regards,
Schnittlauch

"First, No system is safe. Second, Aim for the impossible. Third no Backup, no Mercy" - Schnittlauch

My answer helped you? Don't forget to leave a like. Also mark the answer as solved when your problem is solved. :)

Might try from PowerShell from source and target.

Test-NetConnection -ComputerName "192.168.49.142" -CommonTCPPort "RDP" -InformationLevel "Detailed"

PS C:\Users\hostadmin> Test-NetConnection -ComputerName "192.168.2.2" -CommonTCPPort "RDP" -InformationLevel "Detailed"
WARNING: TCP connect to (192.168.2.2 : 3389) failed
WARNING: Ping to 192.168.2.2 failed with status: TimedOut

From host to vm
ComputerName : 192.168.2.2
RemoteAddress : 192.168.2.2
RemotePort : 3389
NameResolutionResults : 192.168.2.2
MatchingIPsecRules :
NetworkIsolationContext : Internet
InterfaceAlias : vEthernet (InternalNAT)
SourceAddress : 192.168.2.1
NetRoute (NextHop) : 0.0.0.0
PingSucceeded : False
PingReplyDetails (RTT) : 0 ms
TcpTestSucceeded : False

from vm to host:

guidovbrakel_0-1621249227030.png

 

Looks like firewall is blocking, may need to create rules to allow RDP and ICMP. I was also suggesting you run on VM to confirm something is listening.

 

Test-NetConnection -ComputerName "192.168.2.1" -CommonTCPPort "RDP" -InformationLevel "Detailed"