Hyper-V Manager stopped working after updating Windows 11 to th elatest version (22H2)

Copper Contributor

Hey guys, any ideas why I'm getting this after updating my Windows 11 to the latest version?


I'm trying to connect to a Hyper-V server 2019 in the network, something I do all the time using Hyper-V Manager, but all I'm getting now is this:



I don't see the service anymore and when I install the whole Hyper-V feature the service appears, but it still doesn't let me connect to it, I was able to connect before, same user/password, nothing changed on either side (server/client).


Doesn't microsoft want people to use their products?

2 Replies

I do not have a Hyper-V server, but I also get the same error message when I try to mount a VHD/VHDX file. I even went into Services and started the Virtual Machine Management service manually. There is a good chance that a 22H2 update broke it. I also tried to run Windows Sandbox and that reported "The Container Manager service or one of its dependencies is not running." "Error 0x8007041d. The service did not respond to the start or control request in a timely fashion." I have already upvoted this several times in the Feedback Hub app.