How to resolve “MMC cannot initialize snap-in.”

Copper Contributor

Windows 2012 R2. I have at least two snap ins which will not load, eventviewer and DFS management.

I have tried;

  1. SFC scannow
  2. DISM /Online /Cleanup-Image /RestoreHealth
  3. Delete registry key/reboot.
  4. Deleted files in %AppData%\Microsoft\MMC

None of these worked, although the delete registry key trick was supposed to recreate the key automatically, it did not. I reloaded the .reg file.


Everything seems to work well on the server, I can access the event viewer from another server, and do not see any errors.


Where do I go from here?

5 Replies

I'd try a work-around;


Run mmc.exe\File\Add Remove snap-in\Event Viewer\Local Computer\Ok\Ok, File Save As test.msc


does it work?




When I "Run mmc.exe\File\Add Remove snap-in\" I get ;




I do not see the option to \Local Computer\Ok\Ok, File Save As test.msc.

In your picture bottom left list box click the Event Viewer then select Local Computer …………




I do not see "Local Computer" The second image is what I get when I click add.