How to add IdpInitiatedSignon parameter in Windows Server 2012

%3CLINGO-SUB%20id%3D%22lingo-sub-1069660%22%20slang%3D%22en-US%22%3EHow%20to%20add%20IdpInitiatedSignon%20parameter%20in%20Windows%20Server%202012%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069660%22%20slang%3D%22en-US%22%3E%3CP%3E%3CFONT%20color%3D%22%23000000%22%3EI'm%20getting%20difficulty%20to%20configure%20ADFS%20in%20windows%20server.%20I%20tried%20to%20enable%26nbsp%3BIdpInitiatedSignon%20paramater%20by%20using%3C%2FFONT%3E%26nbsp%3B%3CU%3E%3CFONT%20color%3D%22%23FF0000%22%3ESet-AdfsProperties%20%E2%80%93EnableIdpInitiatedSignonPage%20%24True%3C%2FFONT%3E%20%3C%2FU%3E%3CFONT%20color%3D%22%23000000%22%3Ecommand%26nbsp%3BSet-AdfsProperties%20%3A%20A%20parameter%20cannot%20be%20found%20that%20matches%20parameter%20name%20'EnableIdpInitiatedSignonPage'.%20At%20line%3A1%20char%3A20%26nbsp%3Bbut%20appear.%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1069660%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069724%22%20slang%3D%22en-US%22%3ERe%3A%20How%20to%20add%20IdpInitiatedSignon%20parameter%20in%20Windows%20Server%202012%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069724%22%20slang%3D%22en-US%22%3E%3CP%3EThat%20parameter%20is%20only%20available%20on%202016%2B.%20On%202012%2FR2%20it's%20enabled%20by%20default.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069736%22%20slang%3D%22en-US%22%3ERe%3A%20How%20to%20add%20IdpInitiatedSignon%20parameter%20in%20Windows%20Server%202012%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069736%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20response.%20So%20it%20means%20it%20is%20already%20enable%20I%20don't%20need%20to%20enabled%20it.%20But%20when%20I%20tried%20to%20open%3C%2FP%3E%3CPRE%3E%3CSTRONG%3Ehttps%3A%2F%2Fadfs.ad.iblunisys.com%2Fadfs%2Fls%2FidpinitiatedSignOn.aspx%3C%2FSTRONG%3E%3C%2FPRE%3E%3CP%3Epage%20can't%20found%20error%20occured.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069766%22%20slang%3D%22en-US%22%3ERe%3A%20How%20to%20add%20IdpInitiatedSignon%20parameter%20in%20Windows%20Server%202012%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069766%22%20slang%3D%22en-US%22%3E%3CP%3EYou%20probably%20have%20some%20issue%20with%20the%20binding.%20Does%20the%20localhost%2Fadfs%2Fls%2F%E2%80%A6%20URL%20work%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069790%22%20slang%3D%22en-US%22%3ERe%3A%20How%20to%20add%20IdpInitiatedSignon%20parameter%20in%20Windows%20Server%202012%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069790%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20response.%3C%2FP%3E%3CP%3EPlease%20find%20attached%20screenshot%20step%20by%20step%3A%3C%2FP%3E%3CP%3E1)%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F162127i98032D32AB617449%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E2)%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F162128i7C08CDD3B38CA014%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_1.png%22%20title%3D%22clipboard_image_1.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E3)%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F162129i07A667DBC5042AFD%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_2.png%22%20title%3D%22clipboard_image_2.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3Ehttps%3A%2F%2Flocalhost%2Fadfs%2Fls%2FIdpInitiatedSignon.aspx%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20browsed%20mentioned%20URL%20it%20asked%20for%20sign-in.%20When%20I%20clicked%20on%20sign%20in%20button%20%22page%20can't%20found%22%20error%20occured%20but%20I%20refreshed%20page%20%22you're%20sign%22%20message%20display.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1070357%22%20slang%3D%22en-US%22%3ERe%3A%20How%20to%20add%20IdpInitiatedSignon%20parameter%20in%20Windows%20Server%202012%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1070357%22%20slang%3D%22en-US%22%3E%3CP%3EThere%20you%20go%2C%20the%20page%20is%20enabled%2Fworking.%20Check%20your%20bindings%20to%20fix%20it%20working%20on%20the%20other%20hostname%20and%20the%20redirect%20after%20login.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1071303%22%20slang%3D%22en-US%22%3ERe%3A%20How%20to%20add%20IdpInitiatedSignon%20parameter%20in%20Windows%20Server%202012%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1071303%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%20thanks%20for%20response.%20Please%20check%20screenshot%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F162258i71A325E46CE1318E%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_1.png%22%20title%3D%22clipboard_image_1.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3Ebut%20when%20I%20trying%20it%20from%20other%20PC%20%22page%20can't%20display%22%20error%20occured.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F162259i22EB1BEEEF5F1D74%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_2.png%22%20title%3D%22clipboard_image_2.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20find%20further%20snapshot.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F162264i43070E097E4451DB%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EWaiting%20for%20your%20kind%20response.%20Thanks%20in%20advance%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

I'm getting difficulty to configure ADFS in windows server. I tried to enable IdpInitiatedSignon paramater by using Set-AdfsProperties –EnableIdpInitiatedSignonPage $True command Set-AdfsProperties : A parameter cannot be found that matches parameter name 'EnableIdpInitiatedSignonPage'. At line:1 char:20 but appear.

6 Replies
Highlighted

That parameter is only available on 2016+. On 2012/R2 it's enabled by default.

Highlighted

@Vasil Michev 

 

Thanks for response. So it means it is already enable I don't need to enabled it. But when I tried to open

https://adfs.ad.iblunisys.com/adfs/ls/idpinitiatedSignOn.aspx

page can't found error occured.

Highlighted

You probably have some issue with the binding. Does the localhost/adfs/ls/… URL work?

Highlighted

@Vasil Michev 

Thanks for response.

Please find attached screenshot step by step:

1) 

clipboard_image_0.png

2)

clipboard_image_1.png

3)

clipboard_image_2.png

https://localhost/adfs/ls/IdpInitiatedSignon.aspx 

When I browsed mentioned URL it asked for sign-in. When I clicked on sign in button "page can't found" error occured but I refreshed page "you're sign" message display.

Highlighted

There you go, the page is enabled/working. Check your bindings to fix it working on the other hostname and the redirect after login.

Highlighted

@Vasil Michev 

Hi, thanks for response. Please check screenshot:

clipboard_image_1.png

but when I trying it from other PC "page can't display" error occured.

clipboard_image_2.png

 

Please find further snapshot.

clipboard_image_0.png

Waiting for your kind response. Thanks in advance