File Share Write Access Denied to user from one PC

Brass Contributor



I have a user that cannot access a file share from one computer.  Normally replacing the computer or anything like that would be a fine resolution, but in this scenario I can't.  I have however used a backup from a day ago and restored the computer to a previous, 'believed to be working' state.  So I am not entirely sure when it started occurring (as I don't know how often the user uses this computer and it still doesn't work), and I don't have that much retention on the device's backup.  Either way here is what we have.


A domain authenticated user is trying to access \\share\drive\baby\ and save files to the directory.  The permissions haven't changed on the share before it stopped working (they had full control before I changed it today but it wasn't working then so I left it on modify as that is my preference), the account isn't locked, the computer hasn't changed, and I can sign into any other computer as this user, and save to the share in question.  So I am at a loss on what is going on or what to check next. 


Here is what I have tried:

  • For giggles, I removed the user's permissions (as they are explicitly defined by user and not designated by groups), and I added them back (as modify though). 
  • I also tested adding them to a group, giving the group full control, signing out/in of the computer and trying again.
  • I have removed the computer from the domain, deleted the computer object and added it back, and still no dice. 
  • The credentials are not in Windows credential manager for me to clear.
  • Tested from several other PCs as this user and I can edit as needed from them.
  • I have not deleted the account and rebuilt it on the computer, but if there are no other suggestions this is my next step.


Here are some visual aids:







5 Replies
Some tips :

- Always manage permissions using groups, not users.
- Always manage permissions on NTFS level, not network share level.
- Check for error messages/error codes to get a clue as to where to look into.

@Alban1999 Thanks for the reply. 


I 100% agree on the groups, but I am phasing the explicit user definitions out as I go, but this company has share file access in such disarray at the moment.


I am managing the permissions at the NTFS level.  If I made it seem otherwise that was my mistake.


In the event logs I have not discovered an error for this user as of yet.  Is this where you are talking about?  I didn't look too hard though so I will go back and double check.



Today I rebuilt the user account on the computer and I was able to edit with in the share as I should be able to.  However, it completely broke our software and the services that run on the PC (they don't run as the user, but licensing is tied to the user) so I had to restore the PC back to it's previous state.


So the issue is obviously something with this user account on this one PC as to why it cannot edit the share.

Ended up fixing the software to where I could rebuild the user account and everything was fine for 1 day and the user could save to the share.  Yet once again today they cannot modify the share location.  I removed explicit user permissions from the folder with in the share and applied permissions to a group and put the user in the group and still nothing.  At the share level I gave Everyone Full Control and still nothing.

Found that even though the user is signed into the computer, when accessing the share the server sees them as another user account.  I haven't looked into why this is yet, but figured I would update that I have allowed the user the server sees attempting to access the file to the group I created and removed the actual user that is signed in from the group and their access works as it should.