enabling s2d cluster in virtual test environment issue

Brass Contributor


I am trying to setup a s2d cluster within a virtual hyper-v hyper-converged setup with two vms, but when attempting to enable-clusters2d it gets hung up at 27% with "Waiting until SBL disks are surfaced"


Any ideas?



8 Replies

Dell? Firmware. Make sure your firmware is up to date.


What is the East-West fabric (between nodes)?

Are you trying to set this up as a lab between two VMs? If so I have found this can take up to 15 plus minutes depending on your lab hardware. Just ran into this again today be patient it isn't hung. Make sure you add the -verbose switch to enable-clusters2d

So go grab a coffee and try again. Also if it half configured there is a script on the technet gallery called clear-sdsconfig.ps1 they wipes the cluster config and disks and lets you start over.


Dave kawula MVP



My solution to this when I worked on it was to disable-cluster2d, then I re-created the vhdx files, and enable-cluster2d again.



See this blog which outlines the process for creating a guest cluster with S2D:


What hypervisor are you running the VMs on?   Hyper-V?  VMware?  Azure?  AWS?



I am having the same issue....  I have tried it several times.... each time with new VM Builds


  • My Lab environment - Server 2019 DC and HyperV
  • HP DL360 G7 288 GB Ram
  • Storage Controllers P411e for the 4 2.5" 10K 300GB HDD, P411 for the second MSA60, SAS9200-8e for the first MSA60
  • Storage Arrays, 2 MSA60
  • I am creating 2 VMs and attach physical drives from the MSA60 using the SAS9200-8e controller 
  • VM1  2-480GB-SSD, 4 3TB-HDD
  • VM1  2-480GB-SSD, 4 3TB-HDD
  • I used Get-PhysicalDisk to verify all of the disks are up and there are no partitions
  • Once Verified I create the cluster
  • New-Cluster -Name MyS2DCluster -Node MyS2D1,MyS2D2 -StaticAddress
  • Verify the Cluster
  • Then run Enable-ClusterStorage Spaces Direct -Verbose
  • It runs until 27% and hangs on Waiting until SBL disks are surfaced...

Here is the Verbose 


PS C:\Windows\system32> Enable-ClusterStorageSpacesDirect -Verbose

VERBOSE: 2018/08/26-16:25:13.619 Ensuring that all nodes support S2D

VERBOSE: 2018/08/26-16:25:13.650 Querying storage information

VERBOSE: 2018/08/26-16:25:15.578 Sorted disk types present (fast to slow): SSD,HDD. Number of types present: 2

VERBOSE: 2018/08/26-16:25:15.578 Checking that nodes support the desired cache state

VERBOSE: 2018/08/26-16:25:15.578 Checking that all disks support the desired cache state

VERBOSE: 2018/08/26-16:25:26.961 Creating health resource

VERBOSE: 2018/08/26-16:25:32.125 Setting cluster property

VERBOSE: 2018/08/26-16:25:32.125 Setting default fault domain awareness on clustered storage subsystem

VERBOSE: 2018/08/26-16:25:32.344 Waiting until physical disks are claimed

VERBOSE: 2018/08/26-16:25:35.360 Number of claimed disks on node 'MyS2D1': 6/6

VERBOSE: 2018/08/26-16:25:38.422 Number of claimed disks on node 'MyS2D2': 6/6

VERBOSE: 2018/08/26-16:25:38.438 Node 'MyS2D1': Waiting until cache reaches desired state (HDD:'ReadWrite' SSD:'WriteO


VERBOSE: 2018/08/26-16:25:38.453 SBL disks initialized in cache on node 'MyS2D1': 6 (6 on all nodes)

VERBOSE: 2018/08/26-16:25:38.453 Cache reached desired state on MyS2D1

VERBOSE: 2018/08/26-16:25:39.469 Node 'MyS2D2': Waiting until cache reaches desired state (HDD:'ReadWrite' SSD:'WriteO


VERBOSE: 2018/08/26-16:25:39.485 SBL disks initialized in cache on node 'MyS2D2': 6 (12 on all nodes)

VERBOSE: 2018/08/26-16:25:39.485 Cache reached desired state on MyS2D2

VERBOSE: 2018/08/26-16:25:40.505 Waiting until SBL disks are surfaced

VERBOSE: 2018/08/26-16:25:43.552 Disks surfaced on node 'MyS2D1': 9/12

VERBOSE: 2018/08/26-16:25:43.599 Disks surfaced on node 'MyS2D2': 9/12



@Doug Swanson Did you get this resolved?


How are the VHDX files being exposed to the S2D VM Nodes?

When you recreated the VHDX files,


1. Did you create them all individually?  Or, did you create one and copy it to all the others?  Or some combination?

2. Are these fixed or dynamically expanding VHDX disks?

3. Are you using Windows Server 2016 or 2019?  In Windows Server 2019, there is an additional .MHT file for enabling S2D that may give you some hints as to the issue.

4. Did all the S2D tests in Validation pass?

best response confirmed by John Marlin (Microsoft)
Sorry this was a while ago, and I no longer am using the test environment. I now have two working production clusters. Late response unfortunately.