Data Deduplication Commands missing

New Contributor

I am trying to disable Data Deduplication on Windows Server 2012 R2.  When I try to run any of the deduplication commands in Powershell I get the term disable-dedupvolume is not recognized as the name of a cmdlet message.  I get the same message no matter which dedup command I try to run.  I tried running Import-Module Deduplication but that results in no valid module file was found.


I have also tried upgrading PowerShell from 4.0 to 5.1.


Can someone tell me where I can get these commands from?


Thanks in advance.




2 Replies
best response confirmed by dannetsphere (New Contributor)

Hi @dannetsphere 


The commands should be available in once the DeDuplication feature is installed on the server; if you run the below does it show up as installed?


Get-WindowsFeature -Name FS-Data-Deduplication


In addition, can you see the deduplication settings via Server Manager (assuming this isn't a core installation of 2012R2?


Hi @HidMov

I ran the command you provided and it did say the feature was installed.  I was able to copy the files from another server so I'm good now.

There wasn't much info in the Server Manager

Thanks for the reply