Cannot enter key / activate Windows Server 2019 Standard?

Copper Contributor

Ok, I'm just setting up Windows Server 2019 Standard on VMWare running on my desktop.  It's just for personal use.  But, I bought a key for it off the internet.  I just got it in the mail.  It has a PS command it wants me to run to enter in the key.. but it's not working.  See the screenshot.  BTW, it sounds like it thinks I'm offline.  But, I'm able to open IE and browse to Google without issue.

4 Replies

Difficult to read but I'd try;

Dism /Online /Get-CurrentEdition
Dism /Online /Get-TargetEditions

and finally 

Dism /online /Set-Edition:ServerStandard /AcceptEula /ProductKey:12345-67890-12345-67890-12345



Glad to hear, you're welcome.


(please don't forget to mark helpful replies)



@Dave Patrick 

I tried those (in Powershell), but although the DISM reported back as being successful in applying the product key, it was only partially true - it removed the floating text message on the desktop, but nothing else.  Checking System under Control Panel (or Settings) was still reporting as "not activated".


I found the following pair of commands worked though (again, in Powershell). 


  slmgr.vbs -ipk your-product-code-here

to install the product key, then:

  slmgr.vbs -ato

The second command does the actual activation.


Hope that helps anyone else in same situation!:smile: