Cannot add to Domain


I've recently configured and setup a DC and AD account on Server 2019. Configured Hyper-V and ran AD, DC services and and also two other VM's for Windows XP and Ubuntu Desktop. This is a standalone setup and when I want to add windows XP and Ubuntu desktop on a the newly Domain created, it comes up with this error message below however I'm able to ping from server to clients and vice versa 


Please note I've tried the possible solutions below:

1. Turned off Firewall

2. entered the IP address static

3. Reset the Ad and DC server 3 times 

4. gone on other forums to find a solutions 


Appreciate if someone can assist 

25 Replies

It's unlikely an old operating system like XP will be able to join a Server 2019 domain. Better to try a newer supported desktop operating system at least to confirm the domain controller is operational.

Try Windows 10 Enterprise on Microsoft Evaluation Center



@Dave Patrick I've did what you had recommended and used the link to download Windows 10 Enterprise however I get the below error message:


I can ping from Point A to Point B and vice versa. I 'am not sure why its like this and also I've tried putting a static ip address and dynamic as well to see if it goes through, etc 


Please run;

Dcdiag /v /c /d /e /s:%computername% >C:\dcdiag.log
repadmin /showrepl >C:\repl.txt
ipconfig /all > C:\dc1.txt
ipconfig /all > C:\problemworkstation.txt

then put `unzipped` text files up on OneDrive and share a link.




ok will do, shall I run this from the server or client machine?




@Dave Patrick  I couldn't open up the link for OneDrive you had sent through.

Please do not zip the files. Put the files up on OneDrive and share a link.





None of the files have contents. Do not edit the commands.



You must enable SMBv1 on all Domain Controllers WIndows Server 2019


I could not see in the pic. Are you entering the domain name or fully qualified domain name? Try entering the fqdn. Tell me how you.


@Dave Patrick this is what i get from the client machine 



Dcdiag /v /c /d /e /s:%computername% >C:\dcdiag.log (run on domain controller)
repadmin /showrepl >C:\repl.txt (run on domain controller)
ipconfig /all > C:\dc1.txt (run on domain controller)
ipconfig /all > C:\problemworkstation.txt (run on problem workstation)

tried both still the same thing
Is DC windows Server 2019?
correct, running it on Hyper-V
Also note it is a standalone device which I 'am currently testing out before deploying the final production onsite.
I know it should be an easy one joining to a Domain however this is the worst experience I've had in trying to resolve something simple
As I replied top: Was DC enable SMBv1? because with Windows 2008R2 or easier use smbv1 protocol to join domain. Thus if you wanna join Windows XP, enable smbv1 on DC force.
best response confirmed by enaugavule (Contributor)

On Jenserver I'd add server's own static ip address ( listed for DNS then do ipconfig /flushdns, ipconfig /registerdns, restart the netlogon service.

On the DESKTOP-T93V54F I'd add the static ip address ( of domain controller listed for DNS and remove the IPv6 addresses