[Bug Report] Hyper-V Server 2019 Command Line Tools access to the Volume Manager API [Repeatable]

New Contributor

I have found a bug in Hyper-V Server 2019. This may exist in Server Core 2019, but I've wasted my entire day on this already and do not care to try.


My Environment

  • Hyper-V Server 2019 hosts, all identical

  • Synology NAS running SMB 3, current DSM 6 release

  • Dynamically Expanding VHDX files on a Synology SMB share - 3TB each. One formatted to ReFS, the other to NTFS

  • A script is designed to mount the VHDX and Windows Server Backup operations occur on the VHDX

Went to run a one-off backup this morning to the ReFS disk and it wouldn't run. "ERROR - The specified backup location could not be found or is not a supported backup storage location."


Tried to create a NTFS formatted VHDX (assuming it was a ReFS issue) on the HV system, the hypervisors could create the VHDX, could online it, initialise it and create the partition, but could not format it.


Created the VHDX off-machine, moved it over, attempted the backup and it failed with the same error.


Fully patched the HV install to 2021-07, same error.


Ran diskpart list disk - OK
Ran diskpart list partition - OK
Ran diskpart list volume - drive mount point (B:) not shown, volume missing


Go to cmd, can browse and search B:\ fine
Go to PowerShell can browser and search B:\ fine


Use Get-Disk, Get-Partition and Get-Volume in PowerShell - All OK, B drive is displayed as expected in PowerShell's WMI calls


Ran wbadmin get disks which can see the disk but gives:

Volumes: There are no volumes on the disk or Windows is unable to retrieve volume information.

Arduously De-installed the following KB's, rebooting after each

  1. 5003258

  2. 4494174

  3. 4601558

  4. 4589208

  5. 4580422

  6. 5003646

  7. 5003171

  8. 5001342

It all worked again after the removal of "2021-04 Cumulative Update for Windows Server 2019 for x64-based Systems (KB5001342)".


Installed "2021-03 Cumulative Update for Windows Server 2019 for x64-based Systems (KB5001638)" - all fine.


Installed "2021-04 Cumulative Update Preview for Windows Server 2019 for x64-based Systems (KB5001384)" - broken again.


Roll back to 2021-03, all fine again.


It appears that something got into the 2021-04 branch and made it into production which has broken the API for reading the disk information. It is doing this on all of my Hyper-V Server 2019 installs. All of the installs work when rolled back to 2021-03.


All Windows Server 2019 GUI instances that I have are not exhibiting this issue.


A full and more comprehensive write-up can be found at: https://www.c-amie.co.uk/technical/hyper-v-server-2019-cannot-backup-to-or-format-a-vhdx-drive/


Anyone else seen this?

4 Replies

Sounds like you have some good documentation and steps there. Support for confirmed bugs is always free so for immediate help you can start a case here with product support.

Support for business (microsoft.com)




@Dave Patrickthanks for your comments. I tried to be thorough.

Actually getting a bug report to Microsoft these days is a bit of a nightmare. I will try what you suggest.


I have also reported it to the Feedback Hub now at: https://aka.ms/AAd8q27



Yeah... it's still a nightmare. That link just gets stuck in a "you have now been signed out" Azure loop of death and is demanding a credit card to do anything. So what I have done will have to suffice.


Sounds correct, a credit card will be required to secure the support contract, but confirmed bugs are not charged.