Alder Lake 12th Gen Intel CPU won't boot on Windows Server 2022 with HyperV enabled

Copper Contributor

My PC has 12700K, ASUS Z690 mainboard, 64GB DDR5,  and Samsung 980Pro. I'm trying to run Windows Server 2022 on it, but it will not boot when I enabled Hyper-V. It will boot fine without Hyper-V role. I'm just wondering if anyone had tried coupling 12th CORE and Server 2022 OS. Does 2022 handle the Performance Cores and Efficient Cores well?

20 Replies

Doesn't look to be supported.

TUF GAMING Z690-PLUS WIFI D4 | Motherboards | ASUS Gloabl

Windows Server Catalog

this does not mean it cannot or won't work but does mean the process of testing / vetting all components is left to the end user to do.



I've upgraded my home server to alder lake (12700k) recently and ran into the same problem. It couldn't boot into my Windows Server 2019 install.

I've had to disable the efficiency cores in the bios. Windows Server doesn't seem to play nice with them.

It's now been running fine for a month with only 8 Performance Cores. It's a bummer that I can't use the 4 efficiency cores, but it's still been a huge upgrade over the amd 3700x i've had in it before.

I've also tried running Windows Server vNext (Windows 11 Kernel) and it couldn't boot either. The kernel most definitely supports hybrid cores so I'm a bit confused on what the problem could be. I find it interesting that you can boot into Windows Server with Hyper-V disabled, as I couldn't even boot into vNext at all. Maybe the Hyper-V Service was enabled by default on my install.
Thanks. It works.
Why Hyper-V uses kernels that are not designed for it. It is very strange that Windows server is not patched for new processors
 It is very strange that Windows server is not patched for new processors

Well not really since it has never worked like that. The burden of testing / vetting the hardware and submitting for certification has always been on the manufacturer to do.

Windows Hardware Compatibility Program | Microsoft Docs



Server runs on the alder lake but hyper-v can be installed but only with the bcdedit /set hypervisorlaunchtype off setting and this means you can't start the VM error message hypervisor is not running.  Personally I find it strange that hyper-v is not supported on a new CPU.


I found that the Intel Core i9-12900K processor and Hyper-V of Microsoft Windows Server 2022 do not get along very well. As soon as it is installed, already with some errors, the Hyper-V service is no longer possible to boot the entire server. I had to disable all 8 Efficiency cores and leave only the 8 Perfomance Cores running. Only in this way is it possible to boot correctly with the Hyper-V role installed. My Configuration: ASUS Mainboard PRIME Z690-P, KINGSTON DDR-5 DRAM KVR48U40BS8/16 X 4 , INTEL CPU I9-12900K Alder Lake, SAMSUNG SSD 980 PRO NVMe. There is someone who knows exactly the reason for this situation?
Same here with ASRock z690 extreme even after bios update it runs not stable with server 2016,19,22 even with w11 I had troubles with the Microsoft wireless keyboard and mouse lots of delay in typing and movement. replaced all the wireless for cord. Probably the reason is the Alderlake is a consumer cpu and there for not suitable to run a server OS.
I Hope MS would Fix this. Or we should Life with This ?

Xeon chips are P-core only so far, right? Hence Windows Server has not been updated to play with E-cores. 


E-core xeons coming:

@upwander Hello, I'm in the same boat thinking about buying an i9 for a 2022 server. Has anyone tried to set affinity only to P processors for Hyper-v?

Yes i m use I12700K with Asus Tuf B550M and 64GB DDR5 Only P Core Active. I have no issue

Sorry, I mean all processors active by default and apply affinity for Hyper-V only to P processors. This way the server would work with all processors and use only the P cores for Hyper-V. Are you referring to this scenario or do you have the E cores disabled all the time?

Ok sorry 


i have disable the e Cores all time over the BIOS .

I'm not sure if it's related, but Alder Lake doesn't appear to support RSS when Hyper-V features are enabled, at least on Intel's I225 NIC. I have a long thread on Intel's forum where they ultimately blamed MS for the issue (even though Intel's NetAdapter NIC drivers don't appear to properly disabled RSS before the driver is initialized if RSS was previously enabled).

At any rate, this can be tested by disabling RSS via PowerShell on your physical network adapter(s):

(to get the name of your physical NIC(s), mine was just "ethernet")

disable-netadapterrss -name ethernet
(where "name" is the name of your physical NIC)

After this, try to re-enable your E-Cores and see if your system boots properly. If it does boot, you can likely re-enable RSS but restrict to the P-cores. A 12700K has 8 P-cores, which will be processor 0-14 if hyperthreading is enabled (RSS automatically ignores HT cores). Disable E-Cores from your BIOS again to be safe and then run the following via PowerShell:

enable-netadapterrss -name ethernet
set-netadapterrss -name ethernet -maxprocessornumber 14
set-netadapterrss -name ethernet -maxprocessors 4
(again, where "name" is the name of your physical NIC)

Reboot, enable E-Cores in the BIOS, and you should be back up and running with RSS enabled. I am not running Hyper-V, but I'm running Windows 11 with WSL and WSB enabled, both of which use Hyper-V's networking stack. I was getting BSOD's after updating my NIC drivers, which led down the rabbit hole where I finally discovered the above solution. Hopefully this lets you use Hyper-V with E-Cores enabled!

The ultimate solution is likely MS automatically disabling E-Cores for RSS, the same way it automatically disables HT cores.
Eight months have gone by. Has this been fixed by Microsoft? I still have all efficiency cores disabled because of this.

The PC I would like to use as a lab & test - Lenovo M90q Gen3 with i7-12700 does not even have the possibility to turn off efficiency cores in the BIOS, so I am stuck with a great machine with 64 GB fast DDR5 RAM and no chance to use Hyper-V, which is a real bummer. Wish there were some information on whether any updates to Windows 2022 will address the problem...

@Ronny Röe The only option on running a VM, is use Windows 11. Enable the Hyper-v feature.

In Windows 11 you can use all Cores there is no need to disable the cores. But Windows 11 is not Windows Server 2022.


Thanks Robert for the reply.
I will try to find time to re-install with Windows 11 and check if it works. I thought though that most of the core code is shared between Windows 11 and Windows 2002, so it would behave the same way? Anyway, do you think that Microsoft will have an update any time in the future for Server 2022 to support Intel CPU's with a mix of "standard" and "efficiency" cores? Someone wrote that Intel plan to also introduce this to server-style CPU's like Xeon as well and then I guess it has to be addressed?
Don't think there will be an update that this will be fixed. I also came from server and running now Windows 11 and hyper-v the only down side of this configuration is you can't use the server components direct with hyper-v that means storagespaces direct for sample, for me this is a huge bummer, as the setup is not to expensive and you can test or run a lot of configuration setups.
For now work with Windows 11 and you will see it is not that bad ;) hyper-v works perfectly and the VM's runs fast on nvme storage