ADFS Server Error 352 after installing KB4088787

Brass Contributor

I have a 2 server ADFS Farm with a Windows Internal Database on Windows Server 2016 hosted in azure. Yesterday after ADFS01 updated 2018-03 cumulative update for Windows Server 2016 the Service stopped working and showed the behavior as shown in and it even took down ADFS02 which had already installed that update the week before. I tried restoring the server using azure backup from the day before yet the error persisted.


In the end I restored to a point in time were even 2018-02 cumulative update was not installed and everything worked although I also had to restore ADFS02 to the same point in time to get it to work, too.


Ironically, the update I installed was the one that should have fixed an ADFS error caused by 2018-02, which didn't occur in my environment to begin with.


Since I am using update management in azure how am I supposed to get to a current build without destroying ADFS? Should I wait for the next CU?


I am afraid of reapplying the updates since I fear they will break my servers again

4 Replies

Hello Carsten,

i had the same problem, i have resolved with the installation of patch KB4088889.


Thank You 



Hi Fabio,


thanks for the information, I will try to install that patch next week and see if it helps.




best response confirmed by Carsten Stahlberg (Brass Contributor)

Thanks for the link somehow the march cu which caused the problem for me didn't cause any issues this time arround, maybe because the feburary cumulative update was not installed before on the restored vm.

1 best response

Accepted Solutions