Active Directory Replication Status Tool - License Expiring


I need to use the Active Directory Replication Status Tool.
I always have to uninstall and install when I need to use it that bothers me.

The message tells version to download a new version, but the link always takes version 1.1.

Download Active Directory Replication Status Tool from Official Microsoft Download Center



After removing and installing it works. But it already informs the expiry date of the application.




I found several posts related to this problem, but no solution.

I would like an official answer from Microsoft what actually happened with this product.

22 Replies
The licence file in the msi package has not been renewed.
Therefore, a new installation does not work.

Yes, thats correct with the licence File!

Unfortenatly, i dont see any way at the moment to use this tool.


I'm sad :(

Hi @Gabriel Luiz, How are you today? We have the same problem with the Active Directory Replication status tool - License Expired. Do you have the solution from Microsoft already ?

No, unfortunately not. Still no new package to download.

Date Published: 3/8/2021
today i have downloaded latest version, its showing licence date 01-07-2022;
do we have another option to take multi forest-child replication status view.

@Dave Patrick I am curious if you have heard any feedback from Microsoft?  

Any news, what is to be used if this does not work?
Back to repadmin.exe
They fixed it. I have downloaded the file today and it's working again,
Great , sure its working now, Thanks Microsoft team, this is Handy tool
Thank you Microsoft for fixing this, just in time when we need it :)
I opened a case with our Premier support who escalated it. Its been resolved now and there is a new version up as of a few days ago with a valid certificate.

Hello branden, thanks for your help. This issue trigger whenever the certificate expires - I wish Microsoft would simply remove it entirely in the future.
I am still not able to download the latest .msi 1.1 version for AD Replication Tool. When I choose download the older 1.0 Version downloads. I am using link: Please help, I use this tool often.
It always says "1.0" - it's incredibly annoying. If you look at Properties > Details on the MSI file, under the Origin heading, you'll see Content Created is 15 April 2022.
Same problem again so I'm guessing it's just expired after 12 months

Yes this is getting old! MS please remove expiring date from this tool. May 25 2023