OpenID service stopped working after installing ADFS on windows server

Occasional Visitor

Hello to everyone,

We have a developer server and we use it to test various scenarios.


I created a service with OpenIDDict and .Net6, everything was working fine and the url https://auth.myserver.local/.well-known/openid-configuration, served with IIS, was working correctly.

Now our customer asked a SSO with ADFS service, so we tried to implement it.


So I followed this guide:

I installed the ADFS service on my local server (the same server we use for IIS test websites) and I was able to sign in with my AD credentials.


Then I noticed: If I go to the main page of my service (https://auth.myserver.local) the service still works great, but if I try to reach https://auth.myserver.local/.well-known/openid-configuration I receive a 503 error - service unavailable (if I test it on local machine or in a production machine it works great, that's why I think it's my server problem).


I've made some research in IIS logs but I cannot find requests on that url anymore, It seems something is getting the request before IIS.


I tried to stop the ADFS service with no success.

Anyone experienced something similar? My server is Windows Server 2019.



0 Replies