2k16 Clustering - Error loading custom resource DLL

Occasional Visitor

Hello All,

I'm trying to add a custom resource dll into a 2k16 cluster; I'm seeing the same result using both powershell and the failover cluster manager.

I have followed the documentation in for creating custom resource types https://docs.microsoft.com/en-us/previous-versions/windows/desktop/mscs/creating-resource-types 


I took the skeleton from the clipbookserver example and the examples in the cluster api doc cited above.  The command 'Add-ClusterResourceType -Name MyTypeBeta -Dll "C:\Windows\cluster\garbagee.dll"' and am receiving the following prints:

  • INFO [RCM] rcm::RcmApi::CreateResType: (MyTypeBeta, MyTypeBeta, C:\Windows\cluster\garbagee.dll)*
  • INFO [RCM] rcm::RcmGum::CreateResType(MyTypeBeta,C:\Windows\cluster\garbagee.dll,MyTypeBeta)
  • ERR [RHS] s_RhsRpcCreateResType: (126)' because of 'Error loading resource DLL c:\windows\cluster\garbagee.dll.'
  • INFO [RCM] result of first load attempt for type MyTypeBeta: 126
  • WARN [RCM] The DLL for resource type 'MyTypeBeta' is not present.
  • INFO Received notification on resource type that was not findable: mytypebeta

The def file is as follows:


Dll is built for x64. 
I've tried 'extern "C"' for Startup, combining '__declspec(dllexport)'. I've turned off the Props->c/c++->Language 'Conformance mode' and not using precompiled headers. I'm placing the dll and lib directly in the C:\windows\cluster directory on all nodes.

I believe this is something fundamental but cannot figure this out?
Any help is very much appreciated.


0 Replies