Windows Defender Application Guard (WDAG) for legacy Edge not accepting keyboard input anywhere.


My WDAG for legacy Edge sometimes do not accept keyboard input anywhere. I click on address bar, the cursor starts to blink there and when I type nothing happens. The same happens to the search box of the default page (in my case, MSN).

To make matters worse, I may have WDAG running fine for a moment and, just after a reboot, it comes back to this strange behaviour and no keyboard input again. Since I have made absolutely no change on setting on my own, I really can not understand what is going on.

At first I thought there was a hidden interaction with Controlled Folder Access (CFA) enabled but I do not think anymore that this is the reason. Nevertheless, I fix the problem by turning off CFA and rebooting. As soon as I confirm that WDAG is accepting keyboard input I re-enable CFA. Reboot and it is just fine. I leave the computer on for several hours and no problem, Then, a new reboot and voilà, the problem is back again.


Some hints and info:

* Windows 10, 1909 Pro - not a Windows Insider release.

* Windows Sandbox is fine, but I can not type anything in the search box - in this case it seems to be disabled because the cursor does not appear there. Nonetheless, the WDAG problem aforementioned already exists long before installing the Sandbox.

* CFA is turned on and there is no CFA-related event (according to Microsoft Docs) registered in either CFA history or Windows Event Viewer.

* Languages/Keyboard set:
    en-UK/US international
    en-UK/Brazilian Portuguese ABNT-2

* Windows Display Language: en-UK

* Country Region: en-UK

* Reliability Monitor shows only usual software update. No crash.

* DISM/SFC: fine! No problem here.

* I am the administrator of the machine.

* Manufacturer drivers up to date.

This computer has been just reset from OEM Windows 10 1709 and upgraded straight to 1909. WDAG was installed just after that so I could say that there is no old programme causing trouble.


9 Replies

Hi @HotCakeX,


I was trying to avoid the new Edge as long as I could. It is too much new. But, let's try it! It seems I am the sole person in the world with this weird problem :cryingwithlaughter:.


Backup in progress. I will come back as soon as I have installed and tested WDAG+Chromium-based Edge. As usual, this may take a moment... 


See ya!

i hope it's not too late but preferably install an insider channel so you will be able to run it side by side with your current Edge

@HotCakeX, it was not late! Thank you! And I will have my Macrium Reflect backup for peace of mind!

Hello @HotCakeX !


I am writing this from WDAG-enabled Chromium-based Edge (retail version, not the insider one as you suggested). I considered the pros and cons of the insider version and it did not make much difference to me. 


As you can see,  I CAN TYPE, I CAN TYPE! Yesss! Any reference to Frankstein's "it is alive!" is no coincidence at all!:stareyes:


There has been one single crash *after* I have closed WDAG once but it was not logged by Reliability Monitor. So far, so good. Of course, there is some sluggishness sometimes but it has not yet let me down i.e., crashed during use.


The only down side is that OneNote Web Clipper is not yet available for regular Edge Chromium. But I have it on Firefox and it is ok.


I have had no time to make any extensive test. Just restart + open WDAG + type something + close. And again, and again, and again.


Controlled Folder Access was enabled since installation. Furthermore, the following programs from \Windows\System32 have been added manually by me to the list of allowed apps since my previous tests: hvsicontainerservice.dll, hvsimgr.exe, hvsirdpclient.exe and hvsirpcd.exe. 


I will come back later by the end of this week to report if this subject is closed.


Thank you! I was really avoiding the new Edge as far as could. It seems I was wrong.


See ya!





best response confirmed by sandro (Contributor)
Hi, glad to hear you're enjoying the new Edge browser and that WDAG is working as it should :)

OneNote web clipper is available at Microsoft's new Addons store for the new Edge, you can grab it from here:

the new store is located here:

also come visit us at Edge insider community and share your findings or anything Edge related and see the top feedback list plus the upcoming features ^^

Well, time to close this.  Thanks @HotCakeX for your kind and simple suggestion. The new Chromium-based Edge solved it! I have just installed it - and it worked like magic!


Furthermore, I have got some reports of people who say that this new Edge has solved some problems with synchronisation of favourites. Congratulations!


Now that I can use WDAG, I have just noticed another problem. It seems related to the overall virtualisation: .



You're welcome :)
yes favorite syncing got fixed (for now in Canary and Dev and soon will be rolled out to Beta and Stable)
I tried to go to that link but it appears that the message/post is removed

Have a good one!