Get an app to open this 'windowsdefender' link

Copper Contributor

So i have just updated my pc from windows 10 to 11 and saw that the little windows security icon in the bottom right corner showed some recommendations. I tried opening up windows security but it wouldnt. So i navigated to it through the settings menu and then it told me this "Get an app to open this 'windowsdefender' link". I have tried nearly every guide on youtube but nothing has worked as of yet.
i should also mention that i cant find the windows security app under the apps section in settings

27 Replies
ty so much. It seems to be the problem as it wont allow me to enable windows firewall. But the fact is i have just reset my pc (erased everything) and upgraded to windows 11 and i havent enabled any other firewall, that i am aware of.
It tells me that it cannot be enabled because of an existing group policy or because i am using another firewall program.


But you downloaded the tool I shared?

Here is the whole story. I got scammed via discord because of social engineering. Which lead me to run a .exe file (i know, extremely stupid). The .exe file somehow took my discord credentials and google acount info. Thats the reason that i erased everything from my drives and reinstalled windows.
But i did indeed download the tool. It said it could not enable the windows firewall "because of an existing group policy or because another firewall is running". But i havent enabled any other firewall.


First, check Windows activation - connect to your Microsoft account.

Windows Defender broken on Windows 11 and won't open - Microsoft Community

Windows 11 is activated via. a digital license linked to my Microsoft account


To make sure your computer is secure, download the scanner:

Microsoft Safety Scanner Download | Microsoft Learn

It has finished a complete run and found nothing

See if this fix helps you:

Let us know if this helps!

Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.
Already have tried that. Didnt work
Didnt help either... Still same message when i try to open it up
I first tried the Group Policy Editor, it didnt work. I searched for it and ran the editor. But then i gave me an error message and now i cant find it again.
Then i tried the Regestry Editor but there were no key in the path called "DisableRealTimeMonitoring"
Then i tried the powershell command but that didnt work either.
And i cant do the last one cause i cant open the security
I got the group policy editor to work and changed the property of the "Turn off Microsoft Defender Antivirus" as the guide showed. Then i ran the firewall tool but the same message came up. So apparently my computer is running an firewall that i dont know of


Check the task scheduler - there you should see the running tasks by another antivirus.

Cant really find anything but then again i am not really familiar with the tool and i dont know what exactly i am looking for


Preferably - go to your computer manufacturer's technical support - they are the most appropriate to fix this problem.

Because you've taken a lot of steps – no solution.

I dont know why it is acting up. I just went to Control Panel -> System and Security -> Windows Defender Firewall -> Customize Settings. And there i can see that Windows Defender Firewall is enabled on both private- and public network setting