Warning PowerShell ID 300

Brass Contributor


Warning PowerShell ID 300 - Device not ready occurs at every start or starting W.P.S 5.1. 


- <Event xmlns="">
- <System>
  <Provider Name="PowerShell" /> 
  <EventID Qualifiers="0">300</EventID> 
  <TimeCreated SystemTime="2023-02-09T13:24:44.9356909Z" /> 
  <Correlation /> 
  <Execution ProcessID="7524" ThreadID="0" /> 
  <Channel>Windows PowerShell</Channel> 
  <Security /> 
- <EventData>
  <Data>Dispositivo non pronto.</Data> 
  <Data>ProviderName=Microsoft.PowerShell.Core\FileSystem ExceptionClass=IOException ErrorCategory= ErrorId= ErrorMessage=Dispositivo non pronto. Severity=Warning SequenceNumber=13 HostName=ConsoleHost HostVersion=5.1.22621.963 HostId=f904787d-5901-4255-b784-310a76225a8b HostApplication=powershell.exe -ExecutionPolicy Restricted -Command Write-Host 'Final result: 1'; EngineVersion= RunspaceId= PipelineId= CommandName= CommandType= ScriptName= CommandPath= CommandLine=</Data> 


and the following warning appears:

Immagine 2023-02-09 174327.png

And if I open the link I get version 7 which I already have installed.
Is there a solution to avoid this warning?
Thank you

9 Replies
If you start cmd.exe , type powershell.exe -noprofile . Does the error still occur?
yes, i get the same result..
And when you logon to the same computer with another account?
Any update?
Sorry for the delay, unfortunately I don't have another account..
but yesterday i uninstalled powershell 7 and terminal, i reinstalled only powershell 7, but if i run powershell.exe -noprofile it still gives me error...
Ok.. Just to clarify things for me:

- Powershell 5.1 (powershell.exe) doesn't start at all? Or it does and in background the error is logged?
- Powershell 7 (Which you can start from a command-line as pwsh.exe) does work?
Although I have not installed version 5.1 in the apps, running the powershell.exe command it starts, but with error id 300.
while version 7 boots normally without errors.
best response confirmed by Alpha45 (Brass Contributor)
5.1 is included/is part of the Windows OS, it gives an error, and you can't do anything or? Powershell_ise.exe does work?

Personally I don't use 5 that much anymore, 7 is the future . Reinstalling your system isn't an option?
Patience... Powershell_ise.exe is not installed
I'll think about reinstalling!
Thank you