Using SharePoint Online Management Shel - Set-SPOHomeSite not found

Steel Contributor

I have the most updated version of the SharePoint Online Management Shell and it is unable to find the cmdlet Set-SPOHomeSite.


This is the error: Set-SPOHomeSite : The term 'Set-SPOHomeSite' is not recognized as the name of a cmdlet, function, script file, or
operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

I am able to use the other commands like connecting to the tenant. Any suggestion would be appreciated. 

This is the cmdlet documentation

3 Replies

@Eric Adler 


I've got exactly the same issue here after updating to Microsoft.Online.SharePoint.PowerShell 16.0.20212.12000 this morning :sad:

@Darren OMalley It was weird. For me I just had to use a different machine and it worked. No idea why  but, it worked. :)

@Eric Adler 


The fix for this is to remove the SharePoint management shell from control panel and reinstall the latest version off the website


I updated a previous revision and even though the build number was correct, it only works when you install from fresh


hope this helps