Unable to set TeamsFilePolicy

Copper Contributor

Hi,

     I'm trying to update a policy value from teams, the 'CsTeamsFilePolicy'. All the documentation redirects to use powershell.

 

Documentation - Teams native file upload policy 

Documentation - Turn off teams native file upload policy 

 

image.png

 

Every time I try to update this value or create a new CsTeamsFilesPolicy the error 'DefaultFileUploadAppId must be a GUID value' appears: 

 

image.png

 

  • I don't see this property in the cmdlet, either reported anywhere.
  • I have tried with 3 different tenants and all raise the same error
  • I don't see this configuration in the graph API, so I can't manipulate elsewhere
  • I tried to downgrade the module version
  • I don't see any changes to this cmdlet in the releases page 

 

So don't really know if I'm doing something wrong or if the cmdlet it's broken. 

 

Thanks

1 Reply

Hi @dpobo 

Same here. Using the most current MicrosoftTeams PowerShell Module.


I provided Feedback on the Article (on top of the Page) that it does not work

https://learn.microsoft.com/en-us/microsoftteams/turn-off-teams-native-file-upload-policy 

 

Kind Regards

Andres