Sync-PnPAppToTeams error

Brass Contributor

Hi, when i run command Sync-PnPAppToTeams -Identity F8FBB38C-26DB-4B17-B506-35D0706BBA46 a get this error : Sync-PnPAppToTeams: {“odata.error”:{“code”:“10005”,“message”:{“lang”:“en-US”,“value”:“Authentication method is not allowed.”}}}. I’m logged into global admin account. I want to sync an app from tenant globall appcatalog to teams and this error occurs. 

Best regards


3 Replies

Hi @buszi99,

The error message indicates that the current authentication method is not allowed for the operation.

To fix this issue, you can try the following steps:

1. Check App Permissions: Make sure that the global admin account you are using has the necessary permissions to sync the app to Teams. The account should be able to manage apps in the Teams app catalog.

2. Use an App Catalog Admin Account: Consider using an account with the "App Catalog Admin" role in the Teams app catalog site. This role provides the required permissions to sync apps to Teams. You can either add your global admin account to the "App Catalog Admin" role or use a different account with the appropriate permissions.

Add administrator to SharePoint Online App Catalog | Microsoft Learn

3. Before running the `Sync-PnPAppToTeams` command, ensure that you have connected to the correct context. Set the connection context to the app catalog site where the app is located. You can use the `Connect-PnPOnline` cmdlet to do this.

Here's an example of how you can set the connection context and then run the `Sync-PnPAppToTeams` command:

# Connect to the app catalog site
Connect-PnPOnline -Url "" -Credentials (Get-Credential)

# Sync the app to Teams
Sync-PnPAppToTeams -Identity F8FBB38C-26DB-4B17-B506-35D0706BBA46

4. Double-check the `Identity` parameter in the `Sync-PnPAppToTeams` command to ensure it contains the correct App ID of the app you want to sync to Teams. Typos or mistakes in the App ID could cause issues.

Please click Mark as Best Response & Like if my post helped you to solve your issue.
This will help others to find the correct solution easily. It also closes the item.

If the post was useful in other ways, please consider giving it Like.

Kindest regards,

Leon Pavesic

@LeonPavesic when I run this command I'm always logged into a global admin account. Now this site collection behaves weirdly. When I log into sharepoint admin panel and go to apps, I see all my apps are disabled and apps that were avaible for sharepoint and teams now are avaible only for SharePoint. Even if i go to classic app catalog i can't sync to teams.



@LeonPavesic i did everystep you wrote and still problem.