SSH seems to work in powershell but x11 doesn't

Copper Contributor

I have ConEmu working with powershell quite nicely now. I recently tried using <ssh remotehostname> and because I have my own .ssh/config file, public keys, etc... setup it works like a champ. However, whenever I want to open an application on the remote (while in a ssh session) it does not forward x11 which doesn't allow me to see the GUI. What can I do to troubleshoot this?


I've attached (err.png) the console output whenever I try to launch this GUI based application (which happens to be an IDE) using powershell. You can see that it says "Eclipse: Cannot open display: ". I'm stuck on how to proceed here. If you would be so kind to explain in detail how I might resolve to provide further debugging information it would be appreciated. I'm not to familiar with Powershell as I'm always working from within linux.



It's important to mention that I have cygwin64 running perfectly allowing me to use ssh and X11 forwarding just fine. I can start any GUI based application on my remote host through a ssh session without any problems. For completeness I'm attaching (err2.png) the console output that appears from within cygwin64 when I perform the same steps as above.



You can see the same error appears regarding "cairo". Therefore, this package "cairo" is not the issue because the GUI application is forwarded by X11 perfectly showing up on my display. Any ideas to why powershell is not working?

0 Replies