Random error with SharePoint Online PowerShell

%3CLINGO-SUB%20id%3D%22lingo-sub-394070%22%20slang%3D%22en-US%22%3ERandom%20error%20with%20SharePoint%20Online%20PowerShell%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-394070%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20running%20this%20command%20with%26nbsp%3BSharePoint%20Online%20PowerShell%3A%3C%2FP%3E%3CP%3EConnect-SPOService%20-Url%20%22https%3A%2F%2F%24orgName-admin.sharepoint.com%22%20-Credential%20%24userCredential%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMost%20of%20the%20time%20I%20get%20this%20error%3A%3C%2FP%3E%3CP%3EConnect-SPOService%20%3A%20'%3D'%20is%20an%20unexpected%20token.%20The%20expected%20token%20is%20'%3B'.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20try%20again%20and%20again%2C%20it%20eventually%20goes%20through.%20This%20also%20happens%20with%20other%20commands.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20could%20be%20the%20issue%20here%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-394070%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPowerShell%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Frequent Contributor

I am running this command with SharePoint Online PowerShell:

Connect-SPOService -Url "https://$orgName-admin.sharepoint.com" -Credential $userCredential

 

Most of the time I get this error:

Connect-SPOService : '=' is an unexpected token. The expected token is ';'.

 

If I try again and again, it eventually goes through. This also happens with other commands.

 

What could be the issue here?

 

 

0 Replies