New-PSSession giving below error at times

Occasional Visitor
Hi Team, 
 
I am getting below error at times when using New-PSSession. Please do
 
[06:39:57][Step 1/1] New-PSSession : [XXXXXXXX] Connecting to remote server xxxxxxxxxx
[06:39:57][Step 1/1] failed with the following error message : WinRM cannot process the request.
[06:39:57][Step 1/1] The following error with errorcode 0x80090311 occurred while using Kerberos
[06:39:57][Step 1/1] authentication: There are currently no logon servers available to service the
[06:39:57][Step 1/1] logon request.
[06:39:57][Step 1/1] Possible causes are:
[06:39:57][Step 1/1] -The user name or password specified are invalid.
[06:39:57][Step 1/1] -Kerberos is used when no authentication method and no user name are
[06:39:57][Step 1/1] specified.
[06:39:57][Step 1/1] -Kerberos accepts domain user names, but not local user names.
[06:39:57][Step 1/1] -The Service Principal Name (SPN) for the remote computer name and port does
[06:39:57][Step 1/1] not exist.
[06:39:57][Step 1/1] -The client and remote computers are in different domains and there is no
[06:39:57][Step 1/1] trust between the two domains.
[06:39:57][Step 1/1] After checking for the above issues, try the following:
[06:39:57][Step 1/1] -Check the Event Viewer for events related to authentication.
[06:39:57][Step 1/1] -Change the authentication method; add the destination computer to the WinRM
[06:39:57][Step 1/1] TrustedHosts configuration setting or use HTTPS transport.
[06:39:57][Step 1/1] Note that computers in the TrustedHosts list might not be authenticated.
[06:39:57][Step 1/1] -For more information about WinRM configuration, run the following command:
[06:39:57][Step 1/1] winrm help config. For more information, see the about_Remote_Troubleshooting
[06:39:57][Step 1/1] Help topic.
[06:39:57][Step 1/1] At D:\AdminScripts\DeploymentScript.ps1:228 char:24
[06:39:57][Step 1/1] + ... $appServerses = New-PSSession -Computer $s -Credential $appUNPASSWORD
[06:39:57][Step 1/1] + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[06:39:57][Step 1/1] + CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:Re
[06:39:57][Step 1/1] moteRunspace) [New-PSSession], PSRemotingTransportException
[06:39:57][Step 1/1] + FullyQualifiedErrorId : AuthenticationFailed,PSSessionOpenFailed
1 Reply

The error message already tells you what might be the issue. You need to tell us what list items you checked or are having problems.