Is Get-PrivacyManagementRule a valid powershell command ?

Copper Contributor

I've been trying to figure out how a few security settings in the M365 tenant can be configured via Powershell. I was looking into Privacy Management in the admin console which has a bunch of settings I required, for eg- data retention period for Subject Right Requests.

I was not able to find anything in the Microsoft documentations, but after a few hit and trials I found a command - Get-PrivacyManagementRule . Turns out it has a lot of settings/parameters I was looking for. I'm currently not sure whether I can use this command or it will eventually be deprecated since there is literally NO information or documentation about this command from Microsoft.

It has a similar Set command too - Set-PrivacyManagementRule , but again with no documentation for it.

Can anyone with more info on this help me out ? Are these valid commands ?

7 Replies

I dont know about this. Can you share where did you find this cmdlet? maybe it's not a native Microsoft cmdlet and its related to a third-party module.
if you have the cmdlet in your PC , try to run get-command Get-PrivacyManagementRule


@farismalaeb I havent installed any 3rd party module.


See the output of that command below:


PS C:\Users\prakharathreya\Desktop> Get-Command Get-PrivacyManagementRule

CommandType   Name                                     Version          Source
----------- ---- ------- ------ ----------- ---- ------- ----------------- ---- ------- ------
Function            Get-PrivacyManagementRule  1.0                tmp_atkepqnj.kt1

This is because the command has a remote session to a service
try the following command


It's the ExchangeOnline session


Id Name ComputerName ComputerType State ConfigurationName Availability
-- ---- ------------ ------------ ----- ----------------- ------------
5 ExchangeOnli... RemoteMachine Opened Microsoft.Exchange Available


I try to import the exchange management online module and I did not find the command.

even in exchange, I did not see a feature related to Privacy Rule Management.

I think you are using an outdated version, still not sure.

Let me know what are you looking to achieve?


Try to Connect to IPPSession first using below command:

It works only when I'm connected to it.


I agree with you, 

The command is valid and is supported till now, but seems there is no documentation any where.

I checked GitHub and tried to find documentation, but nothing found.

But if the command help you, feel free and keep using it as its still valid and supported.

Hope this answer help