I am unable to run get-ADPermission when exchange 2016 is invoked

Copper Contributor
I tried many ways, but "get-ADpermission doesn't work" it says un recognized. However wen i try with installing (add-snapin Microsoft.exchange ...) it throws error. I am unable to perform any 2016 related task.
9 Replies


Hi @Harshaacharya08,


Could you send a screenshot of the error you get when you type the command "Add-PSSnapinMicrosoft.Exchange.Management.PowerShell.SnapIn"?

Please find the attachment



There is no Attachment

Did you try to start a PSRemote session which should be working fine with you


$Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://YourServer.FQDN/PowerShell/ -Credential $UserCredential


Hi @Harshaacharya08,


There is no attachment. 

I tried this, but wen I call the session I don't get the get-adpermission,for 2010 session I get the option but for 2016 I don't, that's the reason I tried installing the addsnappin, I get the below error


Hi @Harshaacharya08,


Can you run the Get-ADPermission command as follows?


On a server with Exchange 2016 installed


1. Run PowerShell as an administrator.
2. Run the command "Add-PSSnapinMicrosoft.Exchange.Management.PowerShell.SnapIn".
3. Run the Get-ADPermission command.


Get-ADPermission On Exchange.PNG


Run the following command 

Get-PSSnapin -Registered

are you able to see your exchange snapin, if not then I think it's better to reinstall it (I assume this is a management client PC).

Do you have both management module for both Exchange 2010 and 2016 installed on the same PC ( as I understand ) or not.

Hi, Did any solution work for you?!