Get-MpComputerStatus returns no output

Occasional Visitor

Hello,

 

on a Server 2019 with windows defender installed in the "Windows Security GUI" all is fine.

Protection definitions are up to date, exclusions are set ... (managed with SCCM)

 

But when i use the Get-MpComputerStatus it returns no output. (not even an error)

 

Please help.

10 Replies
I'm having the same issue. Did you get this resolved?

@thx1200 

When you run the command 

what do you see in the Windows Event Log 

Application and Services Log \ Microsoft \ Windows \ PowerShell \Operational

Hi

 

Im also experiencing this issue. no output from Get-MpComputerStatus or Get-MpPreference,

 

nothing logged to Microsoft\Windows\PowerShell\Operational when running the commands

@moache 

If you Right-Click on it, can you click on Enable Logging?

@farismalaeb logging is enabled already for that log, just that when running the PowerShell commands nothing is logged the event viewer

Hi

Run the following command

Get-CimInstance -ClassName MSFT_MpComputerStatus -Namespace root/microsoft/windows/defender 

There are no entries in that log when I execute any of the Get-Mp* commands.
There is no output when I query that WMI namespace and class. I also tried Get-WmiObject -Namespace root\Microsoft\protectionmanagement -Class MSFT_MpComputerStatus which also had no output.

 

2021-02-24_00009_LOVEBIRD.png

Here is a screenshot.

@thx1200 

Is Windows Defender registered and working fine, 

is it Enabled or there is a policy which disables it ?!