Get-MpComputerStatus returns no output

Copper Contributor



on a Server 2019 with windows defender installed in the "Windows Security GUI" all is fine.

Protection definitions are up to date, exclusions are set ... (managed with SCCM)


But when i use the Get-MpComputerStatus it returns no output. (not even an error)


Please help.

16 Replies
I'm having the same issue. Did you get this resolved?


When you run the command 

what do you see in the Windows Event Log 

Application and Services Log \ Microsoft \ Windows \ PowerShell \Operational



Im also experiencing this issue. no output from Get-MpComputerStatus or Get-MpPreference,


nothing logged to Microsoft\Windows\PowerShell\Operational when running the commands


If you Right-Click on it, can you click on Enable Logging?

@farismalaeb logging is enabled already for that log, just that when running the PowerShell commands nothing is logged the event viewer


Run the following command

Get-CimInstance -ClassName MSFT_MpComputerStatus -Namespace root/microsoft/windows/defender 

There are no entries in that log when I execute any of the Get-Mp* commands.
There is no output when I query that WMI namespace and class. I also tried Get-WmiObject -Namespace root\Microsoft\protectionmanagement -Class MSFT_MpComputerStatus which also had no output.



Here is a screenshot.


Is Windows Defender registered and working fine, 

is it Enabled or there is a policy which disables it ?!

I have the same issue.
Windows Defender is installed and is running fine.
I can start scans through PS... but I don't get any info from get-mpcomputerstatus or Get-MpPreference
Did you ever find a solution?
I did. The solution for me was to follow the instructions here:

Specifically the Register-CimProvider step is what fixed it for me.

@KimPedersen Not shure anymore how I resolved the issue but it works now for me. 

I have the resemble issue on Server 2019 (4 servers all Dell OEM).
When I use the Get-MpComputerStatus it returns no output. Get-MpPreference also returns no output.
But Get-Command -Module Defender returns output as usual.

The status of Windows Defender antivirus on the SERVER MANAGER dashboard marked "unknown". But I can actually do quick scan etc. Other parts of Windows defender antivirus seems good. like It do update the security patch automatically.

I've tried uninstall/reinstall the Windows Defender antivirus. But don't work. Don't know how to fix it.

Anybody got the same issue or have any idea to deal with this?
Maybe Windows Update patch will fix this?

Hi @Wwhat37 

same problem, did you get this fixed?