Cloud Powershell cannot import module for New-SelfSignedCertificate

Copper Contributor

I'm a Mac user and I've been trying to create a Self Certificate as described in:


When I run the commands in Powershell (via Azure Portal web Powershell) the module for "New-SelfSignedCertificate" is missing and I know it needs to be imported. According to Documentation this module is PKIClient, but I could not find a way to import it and I'm stuck and cannot run the "New-SelfSignedCertificate" command.

Any help you can give? If you know which module can be imported or if you find evidence this doesn't work in the azure web portal it would be greatly appreciated. Thanks


PS: I'm in the middle of a covid19 isolation crysis and I have no Windows machine I can use.



I've also tried this alternative: 

but when I try to save Secure LDAP settings with this certificate in my Azure AD Domain Service it gives error and to check Activity Log (in which I cannot find more details about why it fails)

3 Replies

Afaik that module is not supported on Core, thus it will not run on non-windows installs. Use openssl or any other native tool.

Hi @Vasil Michev , as I explained above, I don't run any PowerShell commands in Mac, I am using Cloud Shell (web interface)

No difference there, that's still PowerShell Core and the cmdlet is not supported.