Windows Update Probelm

Copper Contributor

Hello everyone!

I'm a member of windows insider program but every time I try to update to the latest build I get this error code:


Windows 10 Insider Preview 17035.1000 (rs_prerelease) - Error 0x80240008


Does any one of you have a solution for me?

Thank you!

19 Replies

same here buddy ! tried  every solution but didn't worked for me

same how fix
Same here :(

same issue anyone find a fix


Same here .... just received the above error info ... have tried:


a) Removed McAFee

b) Shifted to Windows Defender

c) Turned off Firewall at Windows Defender

d) chkdsk /r

e) DISM check and restore health

f) run windows update troubleshooter


Any further help/advice would be appreciated.


I too have been experiencing the same error code. However I recently changed the pace of the rates I receive the releases from slow to fast. Up until changing that, I didn't have any problems at all. I'm not sure if it was just coincidence or if in fact it has something to do with that particular setting. I ran the update troubleshooter which now says my "windows updater database potentially corrupt", which the troubleshooter cannot fix. At this point I'm not sure what I should do...

experienced the same error the corrupt one , for this i suggest you to stop windows update service and then run the troubleshooter then it will fix the corrupt issue.
Same here! Windows 10 Insider Preview 17035.1000 (rs_prerelease) - Error 0x80240008 Lenovo Yoga Ultrabook i5
Same here.............I thought,I'm the only one who got that error msg...

Switch to the SLOW ring and install the Windows 10 Insider Preview 17025.1000 (rs_prerelease).
Then you can switch back to FAST ring in order to install the 17035.1000 (rs_prerelase) version.

i am already on 17025 version and i am not able to install 17035 in fast ring ... its just re-downloading , re installing just looping the process....what to do ?

I have just tested this on a fresh install of Windows. Azure joined the laptop with my Olympia credentials then attempted to go straight to Windows Insider Fast ring which is when I encountered the error as well. Switching to Slow has allowed me to install 17025.1000. Still in the finishing touches of slow then will bump up to fast.

I am on 17025 and cannot see 17035 in updates.  It says that my PC is up-tp-date.  I went back to 17017 and then updated successfully to 17025.  Then when I tried to get 35 it again was not seen in windows update.  I have tried all the so called solutions that I found on the net and none of them work.


When the next insider update becomes available is there a chance that this will work?

I had no sooner asked about the next insider build being seen in updates when I went over to the Windows Update Settings and found that 17040 is downloading.  HURRAY!


That was a week of trying to fix the 35 problem to no avail.  Was it all a Microsoft bug again???

update all SYSTEM drivers as well as non SYSTEM driver ie main board drivers can cause this issue

Make sure that you are in the right Windows Ring. You can always Google the build to see what Ring it is supposed to in. This happened to me!!!!! I was receiving Windows Fast Ring, when I am in the Slow Ring!

If you are in the Slow Ring, just disregard that update, until the Slow Ring comes out.

I hopes that this helps!! Just a reminder always  CHECK the build to make sure that it is the correct build for you.

• Windows 10 Insider Preview 17025.1000 (rs_prerelease) - Error 0x80096004

To change or restart the Background Intelligent Transfer Service (BITS)

1. Press Windows + R and type services.msc

2. Locate Background Intelligent Transfer Service (BITS) service.

3. Right-click the Background Intelligent Transfer Service (BITS) service, and then clickProperties.

4. On the General tab, next to Startup type, make sure that Automatic (Delayed Start) is selected.

5. Next to Service status, check to see if the service is started. If it's not,click Start.

To change or restart the Windows Event Log service

6. Press Windows + R and type services.msc

7. Locate Windows Event Log service.

8. Right-click the Windows Event Log service, and then click Properties.

9. On the General tab, next to Startup type, make sure that Automatic is selected.

10. Next to Service status, check to see if the service is started. If it's not, click Start.

Hope this helps.

Reply with the status of the issue and we will be glad to offer further assistance.

@Shahpoor Sadri 

Are you facing this problem with other updates?
Make sure file this issue through Feedback Hub app and add all relevant log files, so Windows team could investigate and reproduce it.