Windows Update freezes at 42% (18282.1000 (rs_prerelease))

New Contributor

Hi, everyone.

I am Pep Jimmy, a new Windows Insider and I am having problems to update to the newest build, which is 18282.1000 (rs_prerelease)

The problem: During the update process (The blue update screen), after just a few minutes the screen, or in other words, everything freezes when it reaches the 42% mark. I restarted the device via force shutdown and rebooting, and tried to redo the update several times. But guess what? Still that 42% hang that is bothering me. I waited for an hour and a quarter (Yes - 75 minutes!) but still no progress.

I have contacted the MS Agents but still could not fix this. Anyone here could provide a method, I would greatly appreciate it.


Pep Jimmy

3 Replies

Hey Pep Jimmy, I just went through a 4 step blog on some items you could do to trouble shoot the situation - In the end depending on what is actually wrong you may have to reset it.  Have a look and see if this sheds any light on your situation, each one varies no doubt but it may give you some good techniques to actually troubleshoot the issue.  When one of my test VMs was stopping, it was at 52% and it turned out it was a bad component within IIS that was broke, and the upgrade just highlighted that.  Have a read and see where it gets you


Thanks, Murray.

What does old software really mean here? Is it software that has been installed for a long time in the computer?

Once again, thanks for your help.
Pep Jimmy


In my case I had installed some really old software on a fresh version of the Windows Beta.  This software installed some really old components that ended up breaking some of the features in the setup of my Internet Information Server - to the point where I couldn't remove the features the old software installed - hence resetting the PC. 

In your case I would look at the event viewer and see if there are any indicators or errors that might point in the right direction.  Using that Microsoft SetupDiag tool may shed some light on the issue as well.  Microsoft also suggests using SFC /Scannow run from an admin command prompt followed by an image clean up with Dism

dism /online /cleanup-image /restore health

If your machine has consistently upgraded ok from Insider version to Insider version, I would generally say the existing software on your PC is probably installed ok, but it is hard to tell.  With the latest upgrade I know a version of vendor software caused a bug check, so there are instances when this does happen.  Have you seen anything in the Event Viewer or used any of the options I have mentioned?