Windows update error 0x80070643 for Windows 11 Pro

Brass Contributor

I'm having issues in using windows update as I'm getting error for 2021-10 .NET 5.0.11 Security Update for Windows 11 for x64 Client (KB5007051) and 2021-10 .NET Core 3.1.20 Update for Windows 11 for x64 Client (KB5007050). I've tried to reset the windows update, I've run DISM and SFC and nothing seems to fix it. 


Can someone help me please?

41 Replies

@setapongThis solved it for me too. Thanks a lot!

Yes, now it's ok!
Mine was too. I suspect the Visual studio update have yet update to newer version this thing and so the update failing... Just had to use WSU hide update tool... And today 5.0.13 goes fine, but the 6.0.1 same thing again... Very disturbing...

This is just because the PC yet have newer version and update fails...
Using the Visual Studio 2022 Installer to update will also fix it. (after updating with Visual Studio installer, Windows update won't show any missing update)
Hi everyone, this morning I found a couple of updates, including the cumulative windows 11 update (KB5008215).
Magically the error on KB5007051 disappeared but on restarting the cumulative update installation error message appeared.

reinstall it, restart same error .....
Do you have visual studio installed on your pc ?
i had the same problem , after updating Visualstudio the problem was resolved
thank you so much for the help offered but my problem got resolved after i installed te other updates that were pending for download and install. thanks everybody for all the help offered here .
Yes this solves my problem I had visual studio now updated windows update is oke to install thx.
Yeah this solved my problem, thanks <3
I did it too now!
It's fixed.
It was interesting that I needed to install the SDK installer to fix it, I had tried both the desktop runtime and runtime installer before I came across your post.
Thanks for the heads up.
I've tried and it worked, thank you.

Fixed after updating VS 2022. Thanks for the tip!!!! 

If you have VS 2022 (or 2019?), run the Visual Studio Installer and install any pending updates.
This update then disappears, I think due to the VS update applying it anyway.

Updating through VS Installer solves the issue.

Thanks dude.
Thank you. we had the same problem. downloaded the installer and ran it successfully!
I continue to have this problem. I have Visual Studio 2022 installed and up to date. In the past, removing previous versions of .Net worked for me. This time, it starts to install, gets to 33%, and then fails. This is the second time in a row I have had problems with .Net updates. Having come from the Unix and Mac sys admin world, it seems to me that these packages don't adequately check for dependencies or installed versions? Maybe my issue will be resolved next week on Patch Tuesday. Fingers crossed.

@Sammy815 With VS 2022 previously installed and then running VS Installer, WUS still produces Error 0x80070643 for 2021-11 .NET Core Update for x64 Client (KB5007885). I also tried running the package from the catalog,  and all items will NOT download (red x) so still nada.

The error is back! Unbelievable!