Windows Subsystem for Linux Preview Can't Find the File Specified

%3CLINGO-SUB%20id%3D%22%5C%26quot%3Blingo-sub-3068988%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3EWindows%20Subsystem%20for%20Linux%20Preview%20Can't%20Find%20the%20File%20Specified%26lt%3B%5C%2Flingo-sub%26gt%3B%3CLINGO-BODY%20id%3D%22%5C%26quot%3Blingo-body-3068988%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3E%3CP%3EI%20downloaded%20the%20Windows%20Subsystem%20for%20Linux%20Preview%20from%20the%20Microsoft%20Store%20last%20year%2C%20and%20it%20said%20%22The%20system%20cannot%20find%20the%20file%20specified.%22%20I%20downloaded%20the%20update%20today%2C%20and%20it%20said%20the%20same%20thing.%20What%20am%20I%20missing%3F%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%26lt%3B%5C%2Flingo-body%26gt%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3C%2FLINGO-SUB%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3069459%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Subsystem%20for%20Linux%20Preview%20Can't%20Find%20the%20File%20Specified%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3069459%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1251566%22%20target%3D%22_blank%22%3E%40philthethrill%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20guess%20uninstall%20the%20Windows%20Store%20option%20and%20install%20it%20using%20Turn%20Windows%20Features%20on%20or%20off%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Harm_Veenstra_0-1642940558666.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F341708i2629DB87F9220168%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Harm_Veenstra_0-1642940558666.png%22%20alt%3D%22Harm_Veenstra_0-1642940558666.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I downloaded the Windows Subsystem for Linux Preview from the Microsoft Store last year, and it said "The system cannot find the file specified." I downloaded the update today, and it said the same thing. What am I missing? I already left feedback on the Feedback Hub 2 months ago. 

 

Windows_Subsystem_for_Linux_Preview_Error_Message.png

11 Replies

@philthethrill 

I guess uninstall the Windows Store option and install it using Turn Windows Features on or off?

Harm_Veenstra_0-1642940558666.png

 

I already had Windows Subsystem for Linux installed long before the Windows Store option became available. Any other suggestions?
https://github.com/microsoft/WSL/issues/7626

- Make sure that File Explorer is set to show hidden and system files.
- Open File Explorer to C:\Program Files\
- Right-click WindowsApps and open properties, then open the advanced security options.
- Remove any specific user accounts (usually with Full Control) from the list and click Apply.
- Click "Change" next to the "Owner:" line and accept the UAC dialog.
- Paste NT SERVICE\TrustedInstaller into the box, then click "Check Names" and OK.
- Check the box next to "Replace owner on subcontianers and objects" and click OK.
- In an elevated PowerShell window, run Remove-AppxPackage (get-appxpackage MicrosoftCorporationII.WindowsSubsystemforLinux -Allusers) -AllUsers
- Reinstall the WSL Preview app from the Microsoft Store https://www.microsoft.com/en-us/p/windows-subsystem-for-linux-preview/9p9tqf7mrm4r
- To check the permissions, run get-acl "C:\Program Files\WindowsApps\MicrosoftCorporationII.WindowsSubsystemforLinux_0.48.2.0_x64__8wekyb3d8bbwe\wsl.exe" | Format-List and make sure that it is owned by NT SERVICE\TrustedInstaller and that your user account does not have access.

@Harm_Veenstra I followed the steps until I got to the part where I can reinstall WSL Preview, but I can't install it. It says, "There has been an error." When I click on see details, it gave me an error code: 0x80070005. Not only that, I can't update any of the apps from the Microsoft Store. For every app that I try to update, it says, "Something happened on our end." It's been like this ever since I followed the steps to change ownership in WindowsApps. I did that on February 8. I didn't have time until then to try it to see if it makes a difference with the WSL Preview app. 

 

2022-02-13.png

 

2022-02-13 (1).png

 

2022-02-13 (2).png

Ok, so the Store has issues itself perhaps? You could try:

Launch The Built-In Windows Troubleshooter:
- Go to Settings.
- Then click on Update and Security.
- Then click on Troubleshooting.
- Go to Advanced Troubleshooting.
- Select Microsoft Store apps.
- Launch them and let the program run.
I did that. It changed the location of temporary files, and it suggested that I reset the apps. I did that, but I'm still having issues with downloading and updating apps. Any other suggestions?
Log off Windows Store and log in again? And you could try running wsreset.exe?
I tried both of those options. I'm still having issues with downloading and updating apps. Is my copy of Windows 11 that I have through the Windows Insider Program faulty? Should I do a reset?
A reset or a complete wipe even perhaps, should fix it but back-up first :grinning_face_with_sweat:

Hello,
Have you tried to install the standard version by using wsl or bash command? To verify whether this version works normally...

I have WSL installed, and I got the WSLg preview update on Thursday from Windows Update. I have tried different Linux terminal apps from the Microsoft Store like Debian, Ubuntu, OpenSuse, and Pengwin, and all of them work really well.

After the latest Windows Update, I was able to download and update apps in the Microsoft Store, but the WSL preview app still gives me the same error message that it can't find the file specified.