Windows Insider for Business requires MFA

Silver Contributor

A while ago i have registered into Windows Insider for Business program with my work Office 365 account (i am also a long time Insider with my personal MS account, but at work i didn't want to use my personal account). I have installed Windows 10 and signed into a program and started getting insider builds. But every time i want to sign in with my work account it asks to create a PIN. Which i don't want to do on a testing only machine. I was able to just dismiss this screen and get to the desktop before, but now it doesn't go away. I am and IT admin for this org. We only have Office 365 E3 and i can't find anything related to this requirement in Azure AD admin center. MFA is not enabled for any user. We don't have Intune license, so i can't check that. It seems though Azure AD joined PC is required to do MFA by default. This is not a problem for a test PC, but if in the future we will decide to join our PC into Azure AD, this can be problematic. We don't want to purchase Intune licenses just to disable it. Maybe i just can't find the right setting or maybe this is Windows Insider for Business requirement. Btw, i don't see this PC in the list of devices in Azure AD, so it seems that it is probably joined into some Insider domain and this requirement comes from it.

2 Replies

I have tried to set up a PIN, received sms with code. After long spinning with Just a moment it let me set a PIN. But then showed an error that server can't be reached (maybe our firewall blocked it) and provided a Skip for now button. I have to repeat this every time i run this PC. Or i can pull the network plug before turning it on, because then it logins with just a password and then i can plug my network back.


I don't know what server and on what port it tries to reach to set or check a PIN. Anyone has an idea?

Have reinstalled this PC with 1803 version (without linking to Insider program yet) and it asked for a PIN and this time it accepts it and logs me in without a password. So it is coming from our Azure AD after all.