Windows Insider 26100 Crashes with iaStorE.sys Upon First Reboot

Copper Contributor

Manufacturer: Dell
Model: Precision 7820 Tower
Current Build: 10.0.26100.1
OS: Windows 11 Pro for Workstations
After a clean install of Windows 11, 26080, and an upgrade to Windows Update, 26100, the system would always crash upon the first boot. The first crash was a "green" screen with iaStorE.sys as the failing component. Subsequent reboots were blue screens with the same error. Since the crash happened following an attempted upgrade to 26100, there were no restore points to which it could revert back. Each crash resulted in having to do a clean install.
In an effort to troubleshoot, I set Windows Update so that it does not provide drivers when checking for updates via LGPO. However, the update to 26100 does not adhere to this setting, thus resulting in a crash during the first reboot following installation.
The only way I could get build 26100 installed in this system was to do the following:

  • Install 26080 to a Hyper-V VM and upgrade to 26100
  • Do a sysprep (generalize)
  • Capture the wim via DISM and split the WIM into install.swm and install2.swm
  • Install to the target system using a USB drive with the updated install.swm, install2.swm


Once the target physical system was clean installed with build 26100, I created manual system restore points. Then, when doing a Windows Update and accepting the drivers provided, I could recreate the same crash with the same faulting driver. However, in this case, I could boot into the install media and revert to the system restore checkpoint.


When I visited the Intel website and manually downloaded the drivers for the afflicted storage device, all worked normally.


The Windows Update driver I believe to be causing the issue is "Intel Corporation - SCSAdapter - (failed)," and it is still being offered via Windows Update.

I will, again, configure Windows Update not to provide drivers, but this is undesirable behavior.

It is important to note that when this system had Windows 11, 23H2, build 22631.3447, it experienced the same crashing behavior with this device driver.



1 Reply