Windows Defender does not detect a virus on Windows 11 (but it does on VM running 10)

New Contributor

Hi there, has anyone had something like this happen to them? I've received a dodgy email with what I'm sure is a virus file attached (an .exe inside a .zip with what should be 'documents').

 

I've was curious so I run a Windows Defender scan, but got a no threats (which seemed suspicious). I did the same on a VM I have running with Windows 10, and sure enough it reports a virus inside the .zip.

 

Sent the sample to virustotal.com and there it appears as detected by 'Microsoft' (as they label it).

 

I'm running build 22579.1.

5 Replies
Check the Microsoft Defender's engine and make sure it is fully updated.
Try restart your PC and update the Microsoft Defender and run scan again.
Would you mind share the name of the malware detected by the Microsoft Defender?

@Reza_Ameri Did all that and still no dice.

The VM is detecting Win32/Wacatac.B!ml.

This is an old virus and should be detected by Microsoft Defender, I advise you to submit the sample of this Malware to Microsoft Anti-Malware team, take a look at:
https://www.microsoft.com/en-us/wdsi/filesubmission
Make sure explain this malware is being detected in Windows 10 and NOT Windows 11.
Before I sent the sample, I tested again, and now it is detected, woohoo!!

I'm now on build 22581 so maybe a fix was put in place?
Great and thank you for sharing, in case it was fresh install of Windows, there is a possibility like Anti-Malware engine is initializing and there might be a new engine update.