Windows apps not working on the latest dev build

New Contributor

I have had an odd issue with the latest version of windows 11.

Last update, these apps was completely fine but when I updated to version 10.0.22483 Build 22483, the apps like Photos, Cortana, Calculator and even the Microsoft Store stopped working.

If anybody would happen to know why this has occurred, please notify me either over email, here or I can provide a phone number and/or Discord name.

For reference, I am from the United Kingdom so some people may not be able to access the phone number provided 

3 Replies
Firstly, this is a public forum , so avoid sharing your email, phone or any personal data because some people might abuse it.
In Dev channel such issues might happen, I believe all apps are stop working, so could you try and see if you are able to open the Feedback Hub app?
Take a look at:

@Reza_Ameri Heya, thanks for telling me, but the thing is, not even that will open since it is linked to the Microsoft store, I already tried to see if I could get it to work

In this case, try follow steps in the website which I shared earlier and see if it solved the issue.