Windows 11 Windows Defender Issue

Copper Contributor

Hi I have an issue with Defender where in every time I open it, it routes me to "You need a new app to open this"

I have tried entering the "
Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage" on powershell (run as administrator) but its not working on my end. It says,

"Reset-AppxPackage : Package was not found.
Windows cannot remove Microsoft.SecHealthUI_1000.22000.1.0_neutral__8wekyb3d8bbwe because the current user does not
have that package installed. Use Get-AppxPackage to see the list of packages installed.
At line:1 char:51
+ Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage
+ ~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Reset-AppxPackage], COMException
+ FullyQualifiedErrorId : System.Runtime.InteropServices.COMException,Microsoft.Windows.Appx.PackageManager.Comman

My Windows 11 is currently updated. I keep receiving this error, see below. Please help.

42 Replies
Die einzige Lösung, die bei mir funktioniert hat.
Thanks your solution worked for me.
Thank you for this beautiful for each. it saved me and fixed the problem.