Windows 11 Windows Defender Issue

Copper Contributor

Hi I have an issue with Defender where in every time I open it, it routes me to "You need a new app to open this"

I have tried entering the "
Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage" on powershell (run as administrator) but its not working on my end. It says,

"Reset-AppxPackage : Package was not found.
Windows cannot remove Microsoft.SecHealthUI_1000.22000.1.0_neutral__8wekyb3d8bbwe because the current user does not
have that package installed. Use Get-AppxPackage to see the list of packages installed.
At line:1 char:51
+ Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage
+ ~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Reset-AppxPackage], COMException
+ FullyQualifiedErrorId : System.Runtime.InteropServices.COMException,Microsoft.Windows.Appx.PackageManager.Comman

My Windows 11 is currently updated. I keep receiving this error, see below. Please help.

42 Replies
It is working for me thanks :)

I found this powershell command which solves my Package Not Found issue.


add-appxpackage -disabledevelopmentmode -register ((Get-AppxPackage Microsoft.SecHealthUI -allusers).InstallLocation + '\AppxManifest.xml')
Thanks for your solution. It has worked for me as well as many others.

Here is a way to limit its scope (and prevent tons of PowerShell messages):
Get-AppxPackage -User <COMPUTERNAME\ADMINUSERNAME> -Name "Microsoft.SecHealthUI" | Foreach [...]
([...] to indicate that the Foreach bit remains as before)

I had been able to reset the local admin account using the oft-described Reset-AppxPackage PowerShell one-liner. For my standard user, this did not work because the package was not registered.
The adapted solution gets the missing package from the admin user and registers it to the standard user.

In order for this to work, it may be necessary temporarily to upgrade the standard account to an admin account so that PowerShell (Admin) can be run under this account.

@mfdesign thanks! Perfect.

Well the: Get-AppXPackage | foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

didn't work for me: After that the securtiy app would just crash on start (after a reset). Then settings app crashes.. windows exlporer not working properly.. no more button on task bar.


Seems I am forced to revert to 10 or reinstall windows..


@mfdesign thank you it finally worked. I was having this this issue for like 2 months

bro tysmmm i literally was like looking up on yt for hours and finally it worked cuz of u

@mfdesign  I had the same issue and this solution worked! Thanks!

Thank you. Many online methods useless. You method are useful. Thanks
Thank you, the solution with Add-AppxPackage was helpful for me but not complete.
For me the entire folder C:\Program Files\WindowsApps\Microsoft.SecHealthUI_1000.22000.1.0_neutral__8wekyb3d8bbwe was missing.
I recovered it from windows iso but it then wasn't on the list. I registered it using

Add-AppxPackage -DisableDevelopmentMode -Register “C:\Program Files\WindowsApps\Microsoft.SecHealthUI_1000.22000.1.0_neutral__8wekyb3d8bbwe\AppXManifest.xml”

but that in turn put it into status:

Status : Modified, NeedsRemediation

and wouldn't let me run it.
I tried creating new profile, repair installation and multiple troubleshooters but it all didn't work. Finally I just removed the "NeedsRemediation" flag in the registry.
Just open regedit and go to:


then remove Microsoft.SecHealthUI_8wekyb3d8bbwe key from the list.
Took me couple of hours but it finally works.

Thanks bro after trying every thing this worked @eugeneanghm 

Thanks @eugeneanghm ... it worked for me!

Just tried this method in April 2022. Worked like a charm. Thanks! The other method shown earlier in the post did not work on my system.

me acabas de salvar la vida amigo gracias!!!!@mfdesign 

Solution worked for me, I was having same issues where it was saying package not installed. Great fix thanks  @mfdesign 

This really works! Thank you!


Use the same command but instead of PowerShell use Developer PowerShell for VS 2022.

This is the only solution that works for me!
Thanks mfdesign. This solution worked for me.