Windows 11 Update still says PC does not meet requirements after issues fixed

Copper Contributor

Windows 11 update told the PC does not meet the requirements (TSM and EUFI).

After fixing this issues in the BIOS and running the health check, it is all ok.

When I open Settings -> Update & Security, there is still a red cross.

Reboot didn't help.

Looks to me a bug in the Windows Update that some flag is not cleared after fixing the issues.







44 Replies

@No_Money_Mo_Problems Tried that, no joy. Everything in bios is correct, PC health check is good, processor on list of compatibility, but Update still has red x, with not compatible with CPU. I5-10500t is on the list. Tried installing from USB, with the reg bypass, still no luck. :rolling_on_the_floor_laughing:

Same problem on my side When will the Update roll out on Version 21h1?
For anyone still having this problem just run
Like another user already said, worked perfectly for me!



Worked for me!


Thanks for the tip!  After converting to GPT and Secure boot, was getting still "not supported", even though PC Health told me all was OK.


Changed the time, rebooted, and bam! downloading the Win 11 upgrade now. Set the time back to auto.



its 2024 and still an issue, for a customer last week i installed windows 10 on 3 11th gen i5 computers, and these computer came new with windows 11 yet i noticed this false statement in windows update, Microsoft must want people to stay on 10 , lol   @Rene_Balvert