SOLVED

Windows 11 update error (Something went wrong. Try to reopen settings later)

Occasional Contributor

I was on Reddit when I saw the new windows 11 update, it looked cool and wanted to update; I opened the update manager and got this weird message: Something went wrong. Try to reopen settings later.

I searched on the net but only found windows 10 issues, I still tried to fix them with their solutions but nothing worked, but I discovered something. When running: net start wuauserv, I get this error: System error 1058, which says: Impossible to start the service: the service is disabled or it is not associated with any device. I then tried to start it manually, but it won't start since it is a service that is called by windows update when you open the settings. Lost in this mess, I contacted Microsoft support, and they sent me here. Any ideas?

14 Replies

@Marel_  Hi

Please provide more details - what update are you writing about?
what build do you currently have for Windows?
Often the update service gives such a message because there are not all the components needed for installation and you just have to wait!

It's the latest update that got released, my current build is the 22543.1000.

@Marel_ 

It seems that everything is fine with you - I would not worry about the notification without the error code.
Please inform me:
https://docs.microsoft.com/en-us/windows-insider/flight-hub/

@Marel_ 

Announcing Windows 11 Insider Preview Build 22557 | Windows Insider Blog

 

I suggest you wait not everyone has immediate access to updates,

of course, you can download the ISO and install it manually.

Good luck

@Andrzej1 

The problem is that windows update does not even show, here's a screenshot (it's in Italian tho)

Marel__0-1645112021447.png

 

@Marel_ 

I think that in a few days everything will be fine

Using ISOs - Windows Insider Program | Microsoft Docs

And this is in case there are still problems.

I'll try, thanks for the help!
I have the same problem for over a month and I think I am missing some updates too. I can't even install them manually. So maybe you should take a closer look at it.

I found out that I have a process called: "StopUpdates10Service", this little guy gets installed as a sponsored program when you install something else.

To delete it just search for it in the task manager, go on the file path, stop the process and delete it.

best response confirmed by Marel_ (Occasional Contributor)
Solution

I just fixed everything, I got quite the headache while doing all of this, here's an ordered list of what I did:
1. Stop the SU10 process from the task manager;
2. Remove manually the SU10 program (you can go to the path through task manager);
3. Disabled the "SU10" process from "services";
4. Activated the "Windows Update" process from "services";

5. Activated the "Orchestrator" service from "services"
6. From Regedit, I got to "HKLM\SYSTEM\CurrentControlSet\Services\WaaSMedicSvc" and changed the value of "start" from 4 to 2
7. Restarted the PC.

That should be the way to fix it, at least it worked out for me
@Diering1825

@Marel_ 

 

I already got my computer to recovery point but I will save your post if this will not work, by now I see that I can download old updates so it looks good. 

Thanks
it's the only method that worked in my case :happyface:

@Marel_ I have the same error in my windows update setting did u get a solution ?

@Marel_ 

Hi, I also experienced this after i updated my PC to Windows 11 but i fixed mine by running an application named "QOZ9F9" that is somehow related to SU10Guard inside Windows Directory.image.png

after running that application, this has showed to my screen:image.png

Just Click the "Restore Windows Updates" and it will fix the issue on updates.
By the way, sorry for my bad grammar but i hope this helps.