Windows 11 update doesn't come on dev channel

%3CLINGO-SUB%20id%3D%22lingo-sub-2794344%22%20slang%3D%22en-US%22%3EWindows%2011%20update%20doesn't%20come%20on%20dev%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2794344%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Hichkas_1-1632901633608.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F313523iD9918B1DE420C6CE%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Hichkas_1-1632901633608.png%22%20alt%3D%22Hichkas_1-1632901633608.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Hichkas_0-1632901621302.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F313522iA5063BA3AAAFEDA8%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Hichkas_0-1632901621302.png%22%20alt%3D%22Hichkas_0-1632901621302.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThat%20is%20my%20situation.%20I'm%20in%20dev%20channel%20but%20am%20not%20receiving%20the%20update%2C%20it's%20been%20a%20week.%20Any%20solution%20to%20that%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hichkas_1-1632901633608.png

 

Hichkas_0-1632901621302.png

 

 

That is my situation. I'm in dev channel but am not receiving the update, it's been a week. Any solution to that? 

 

2 Replies
You need to sign in with Windows Insider account, and that's a Microsoft account you used to sign up for Windows Insider program. Additionally, make sure your system meets Windows 11 requirements.

https://docs.microsoft.com/en-us/windows/whats-new/windows-11-requirements
Hello.
Have you checked for optional updates?